mysql cluster with load balance

Discussion in 'Technical' started by minus4, Dec 13, 2007.

  1. minus4

    minus4 New Member

    hi there,

    im using debian etch 64 bit (AMD) and have followed the how to with regards to mysql cluster, now all seems fine, a cluster is running, load balance is one on one off and all test pass.

    but i have a couple of problems:

    one mysql node is now unaccessable via SSH, so i have to use kvmoip
    i have a virtual ip of xx.xx.xx.xx if i use this i get nothing unless im in the actual IP group, but i need this to be accessable from the web farm that is on another subnet ????? what am i doing wrong ?

    also when i actually try mysql from within the subnet i just get a hang after entering my pass and i have to press control and Z to exit!!!

    i would be grateful for some uncomplicated guidence on this as i am new to linux and everything is a nightmare.

    p.s i could not install ultramonkey as they dont have a 64bit amd yet, but i have everything running with regards to db:mysql, heartbeat etc all as seperate installs.

    i have an update on the error from mysql:

    shell> mysql
    ERROR 2003: Can't connect to MySQL server on 'host_name' (111)

    i have done netstat -ln grep mysql

    and i get this:

    unix2 : {acc} stream listening 12555 /tmp/mysql.sock

    i can connect if i go direct to the ip of the node and port 3306

    another update:

    i have this : net.ipv4.conf.eth0.arp_ignore = 1

    i assume this blocks all traffic except for traffic on the current subnet ????
    do i just comment this out? and the use ip sec ???
    thanks
     
    Last edited: Dec 13, 2007
  2. minus4

    minus4 New Member

    okay i have everything running just one thing

    i need to access the virtual IP from outside the newtork, ie from the web cluster

    any idea's folks !!!
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Just forward port 3306 (MySQL) from your router to the virtual IP address. The web cluster must then connect to your router's public IP.
     
  4. minus4

    minus4 New Member

    hi thanks,

    in my firwall i have this:

    name: mysqlvirtual
    ip: <virtual IP>
    from: ALL
    to: <virtual IP>

    is this what you mean, because i tried to telnet and still nothing

    can i just say i dont have any other IP addresses, i have one subnet of public ip's
    everything is blocked except for out and port 3306 by a firewall but ip addresses stay the same
     
    Last edited: Dec 14, 2007
  5. minus4

    minus4 New Member

    everything is spot on exept for this

    IP Virtual Server version 1.2.1 (size=4096)
    Prot LocalAddress:port Scheduler Flags
    -> RemoteAddress:port Forward Weight ActiveConn InActConn
    TCP 192.168.0.105:3306 wrr
    -> 192.168.0.101:3306 Route 1 0 0
    -> 192.168.0.102:3306 Route 1 0 0

    with my IPS but

    -> 192.168.0.101:3306 Route 1 0 0
    -> 192.168.0.102:3306 Route 1 0 0


    weight says 0 0 before it said 0 1 is this anything ????????
     
  6. minus4

    minus4 New Member

    hi falko

    i have an update, on the sql node i see this on boot:

    error: net.ipv4.conf.eth0.arp_anounce is an unknown key
    says the same for ignore too.

    these are lines you have said to add !!!

    does it matter that mine shows as ipv6 ????

    should i change the 4's to 6 maybe, what do you think

    or anybody else !
     
  7. minus4

    minus4 New Member

    well thanks falco

    guess ya dont know ya own shit hay

    and i thought the linux community was supposed to be good, at leeds with windows people actually help.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    I do, and it's working for me. If I knew how to help you I'd have posted an answer.
     

Share This Page