MySQL Cluster On FC5 : error while unpacking from engine

Discussion in 'HOWTO-Related Questions' started by asyadiqin, Oct 25, 2006.

  1. asyadiqin

    asyadiqin New Member

    I have 1 management node (192.168.0.1) and 2 storage nodes (node1:192.168.0.2 / node2:192.168.0.3).

    On the mgm node, the config.ini is as follows :-

    On both node machines, the my.cnf are as follows:

    On the mgm node, these are what is shown in the mgm console.

    Previously, I have created a test database with 1 table (cluster.table_1). Below is the error in both storage nodes.

    First of all, what is happening? Is there anyway I can either access or delete that database at all.

    I am quite new to MySQL clustering and do not understand why this is happening. Any help is appreciated. Thanks.
     
  2. mobilehunter

    mobilehunter New Member

    I'm new to this cluster too, but from my experrience, i think better wait until the nodes in connected state on in starting state.
    Some time it takes time to connect.

    Hope help
     
  3. asyadiqin

    asyadiqin New Member

    Thanks for the info. However, you can see that the 2 nodes are connected to the mgm node.

    Anyone have any idea what I should do to correct this?
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Maybe the table is corrupt? You can try to repair it. Also, is there enough disk space on each node? What's the output of
    Code:
    df -h
    on each node?
     
  5. asyadiqin

    asyadiqin New Member

    This is a freshly installed server with 80GB harddrive. So I don't think that diskspace is the issue here.

    Maybe the table is corrupt. If so, how do I repair it?

    Another thing is that I tried creating another database. When I tried creating a table in that database, it said the table exist, even though its an empty database.

    Any ideas?
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  7. asyadiqin

    asyadiqin New Member

    Thanks for the info, Falko. However, it seems that the repair was meant for MyISAM. Will this work for tables using NDBCLUSTER engines?
     
  8. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Good question. Never tried that...
     

Share This Page