MySQL Cluster Howto-Lo0 problem

Discussion in 'HOWTO-Related Questions' started by tfunky, Mar 11, 2007.

  1. tfunky

    tfunky New Member

    Hello,

    I've followed the Mysql cluster on Debian Sarge howto and I have a problem that I can't seem to get past.

    When I reboot the mysql servers, lo:0 doesn't come back up. I have to do a ifup lo:0

    This is what I have in the /etc/network/interfaces on both boxes

    <code>
    # The loopback network interface
    auto lo
    iface lo inet loopback

    auto lo:0
    iface lo:0 inet static
    address 192.168.1.107
    netmask 255.255.255.255
    pre-up sysctl -p > /dev/null

    </code>

    With the exception of the changed IP address, that's what's in the howto. Also, if I'm thinking it through correctly, the "auto lo:0" line should fire the interface up at boot, right?

    Can someone point out what I'm missing here?

    Thanks!

    Tfunky
     
  2. martinfst

    martinfst HowtoForge Supporter

    It's probably not lo:0 but eth:0 for the interface name.
     
  3. tfunky

    tfunky New Member

    I probably should have given more info.

    The clustered database systems are using lo:0 as the to listen to the virtual IP address for the database cluster, so I'm pretty sure that it is supposed to be set up on lo:0. (eth0 is used for the box's real ip address)

    That all being said. Shouldn't that commands listed bring up the loopback subinterface (lo:0) at boot?

    Thanks!

    Tfunky
     
  4. martinfst

    martinfst HowtoForge Supporter

    Sorry I meant eth0:0.
    The lo entry is for 127.0.0.x.

    You can have / should have multiple IP's on the eth0 interface. That's where the systems communicate on. localhost is ONLY used inside a system. Thus it's not possible to talk to an external system over lo interfaces.
     
  5. tfunky

    tfunky New Member

    hmmmm....

    What you're saying makes sense. Maybe there's just an error in the howto?

    I'll move it over and to eht0:0 and see if it still works and report back.

    Do I still need the dev/null, etc?

    Thanks!

    Tfunky
     
  6. martinfst

    martinfst HowtoForge Supporter

    Code:
    >/dev/null
    just means to discard output. Any response/output of the command in front of the '>' sign is lost. It's sometimes useful to remove the > /dev/null to see the actual output and if oke, add it again. It can hide too much ;)
     
  7. johN5Five^

    johN5Five^ New Member

    Can i knw why the netmask is 255.255.255.255??? why not 255.255.255.0???:confused:

    And i setting up a mysql cluster follow the howto..but hving problem..
    my virtual ip is 10.100.100.105, what should the netmask be???

    sori i m newbie to network stuff:(
     
  8. falko

    falko Super Moderator

    Try 255.0.0.0.
     
  9. johN5Five^

    johN5Five^ New Member

    Code:
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    auto lo:0
    iface lo:0 inet static
    address 192.168.1.107
    netmask 255.255.255.255
    pre-up sysctl -p > /dev/null
    which i wanna understand is ,y the tfunky's conf file, his address is 192.168.1.107 class C. But his netmask is 255.255.255.255 ??? :confused:

    Why subnetmask of Class C address not 255.255.255.0 ???
     
  10. falko

    falko Super Moderator

    Because that IP address is used only on the system itself - it's a virtual loopback device.
     
  11. johN5Five^

    johN5Five^ New Member

    i try 255.0.0.0, but cant work..all cluster notes is failed when ifup lo:0 is run.
    but i changes to 255.255.255.255 it able to run it now..:) thx
     
  12. My Eyes They Burn

    My Eyes They Burn New Member

    tfunky,
    what was your solution to this? I've been having the same problem both on a mysql cluster and a mail cluster.
     
  13. My Eyes They Burn

    My Eyes They Burn New Member

    Nevermind, I finally figured it out - for anyone else have problems and searching. The loopback interface lo:0 with the virtual interface has to be at the end of the /etc/network/interfaces file, after all other interfaces. At least that's the only way I got mine to continually come up.
     

Share This Page