mysql checkbox missing

Discussion in 'Installation/Configuration' started by mishko, Feb 15, 2008.

  1. mishko

    mishko New Member

    hi guys i`ve problem with fresh ispconfig instalation on my ubuntu 7.10 box and ispconfig version 2.2.21 everything run OK but in ispconfig i`m missing by adding and/or editing site that mysql checkbox to allow sql on that site

    here is picture of my form:

    i check the form manager if there is everything allright and seems that it`s OK

    picture here:

    so i can`t make site with mysql support and add new database and user to it in options tab.

    don`t know what`s wrong pls help :(

    PS: ofcourse i try all of this as admin
    Last edited: Feb 15, 2008
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is mysql enabled in the limits of the reseller were this site and client belongs to?
  3. falko

    falko Super Moderator ISPConfig Developer

    What strikes me is that Ruby isn't available in the web form... :confused:
  4. whimboo

    whimboo New Member

    I have the same problem. The checkbox isn't even visible in the reseller limits. There I have only the possibility to enter the amount of databases. I think that's the cause why it's not working for customers.

    I hope this could be solved soon because I'm not able to create any web with mysql access. :/

  5. mishko

    mishko New Member

    yes resseler have mysql sets at -1
  6. mishko

    mishko New Member

    for now I create DB directly in phpmyadmin but this is no good for clients cuz they can`t manage their DBs
  7. falko

    falko Super Moderator ISPConfig Developer

    I've just tried to reproduce this behaviour, on an upgraded and also on a new ISPConfig installation, but it is working for me as expected.
    Can anyone else confirm this behaviour?
  8. rsun

    rsun New Member

    my new installation of ISPConfig 2.2.21 has a MySQL checkbox right next to it.

  9. whimboo

    whimboo New Member

    I was upgrading from 2.2.19 to 2.2.21. No idea if this could be the cause of the problem.

    I did a short check into the code:

    if(is_array($val->elements) and $deck_id == $key){
    // gehe durch alle Elemente des Decks
    ==> while (list($element_key, $element_val) = each($val->elements)){

    // wenn Element sichtbar ist
    if($element_val->visible == 1) {
    // value = Wert aus Datenbank, ansonsten Standartwert aus Objekt (Voreintrag)
    if($tablevalues[$element_val->name] != ""){
    $value = $tablevalues[$element_val->name];
    } else {
    $value = $element_val->value;
    // TB 13.06.2007
    if (get_magic_quotes_gpc()) {
    $value = stripslashes($value);

    At the mentioned position only over following elements is iterated:


    This is the limits deck for a reseller while logged in as admin.
  10. whimboo

    whimboo New Member

    Sorry I did a failure. This is the correct list:

    limit_web: 1
    limit_disk: 1
    limit_traffic: 1
    limit_traffic_ueberschreitung: 1
    limit_user: 1
    limit_domain: 1
    limit_domain_dns: 1
    limit_slave_dns: 1
    tr_l1: 1
    limit_dns_manager: 1
    limit_httpd_include: 1
    limit_shell_access: 1
    limit_cgi: 1
    limit_standard_cgis: 1
    limit_php: 1
    limit_ssi: 1
    limit_ftp: 1
    limit_anonftp: 1
    limit_frontpage: 1
    limit_mysql: 0
    limit_mysql_anzahl_dbs: 1
    limit_ssl: 1
    limit_wap: 1
    limit_error_pages: 1

    The number behind is $element_val->visible.

    So the mySQL box isn't shown. Even Ruby isn't in this list. How can I get them back?
  11. mishko

    mishko New Member

    whimboo I find that this information are in ispconfig DB for each reseller in table "isp_isp_reseller" but this is useless for admin just for reseller.

    the problem is in: limit_mysql = 0

    I tryied to make new resseler and than look in DB and as I expected cause i don`t have mysql checkbox so limit_mysql is false. when i manualy change it to true just for test it`s worthless no checkbox is showing
  12. Skumfidusen

    Skumfidusen New Member

    Im having the same problem. After i updated from 2.2.19 to 2.2.21 it wont show the checkbox.

    Im using admin login.
  13. dron

    dron New Member

    I have this problem too. All started when I upgraded from version 2.2.8 to 2.2.21. But I had troubles during install - for the first time I didn't have up-to-date version of gcc so install faild with /root/ispconfig directory removed. well, next try was install from scratch (only ispconfig). after successfull install (with old ispconfig db in mysql) I found out all working fine but mysql checkbox is gone - exactly like on the screenshot in the first post by mishko.
  14. blackice

    blackice New Member

    I have the same problem, after upgrade no mysql ticket is showing... no ruby on rails 2...
    Could this be because i have manually installed ruby on rails before?

    Help plz...
  15. dron

    dron New Member

    btw. when I make some changes in web site form and save them, mysql db for this website is deleted (for me it looks like consequence of missing mysql checkbox - aka. its considered as off). I am a little bit scared to do any changes now, at night I will do backups and will try downgrade to 2.2.19. but I am afraid of some error in my ispconfig db (although in ispconfig self check it seems to be ok)

    btw. is there any tutorial or hint what exactly should I backup?

    btw. my present configuration is CentOS 5.1, but the problem started on Fedora Core 5 - I reinstall whole distro in the meantime...
  16. blackice

    blackice New Member

    Had the same problem!

    Try to backup the userdatabases from ispconfig or use webmin... I use scheduled backup from webmin.
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    I checked this and was not able to reproduce it until now.

    Please post a screenshot of the limits tab of the reseller were the site belongs to and of the website settings were the problem appears.
  18. blackice

    blackice New Member

    Hello Till !

    I'm adding the sites as an admin...

    Also the siteas that allready have a database dont show a database list when i click on the options tab...
  19. Skumfidusen

    Skumfidusen New Member

    I tryed to run the install again and now the checkbox is there.
  20. falko

    falko Super Moderator ISPConfig Developer

    Can anybody with a missing MySQL checkbox here describe *exactly* what he did before the checkbox went missing, and if it's missing only for the admin, for the reseller, for both, etc. I need as many details as possible because I haven't been able to reproduce this yet.

Share This Page