MySQL auto stop

Discussion in 'Server Operation' started by mxtdn, Nov 6, 2009.

  1. mxtdn

    mxtdn New Member

    Dear all,

    I'm new here, and i use "The Perfect Server - CentOS 5.3 x86_64 [ISPConfig 3]" of Falko.

    I do'nt know why my mysql auto stop that make all my sites can't connect.
    When I restart the server, nothing happens.
    Could you please help me ?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your logs?
     
  3. mxtdn

    mxtdn New Member

    Hi falko,
    This message in control panel ISPConfig 3.0.14 ( tab: minitor ):
     
  4. falko

    falko Super Moderator ISPConfig Developer

    That has nothing to do with MySQL. Do you see any errors in your logs when you restart MySQL?
    IS this a physical server or a virtual machine?
     
  5. mxtdn

    mxtdn New Member

    Dear falko,

    No error when i restart mysql.

    My server is physical.
     
  6. falko

    falko Super Moderator ISPConfig Developer

  7. mxtdn

    mxtdn New Member

    thanks for your help.
     
  8. mxtdn

    mxtdn New Member

    help me

    Dear Falko,

    i was resetup myserver with thread "The perfect ... centos5.4 with Ispconfig3".
    However,I still have following errors:
    Until undefined time, all sites on server lost their connection to MySQL. Then, they will automatically connected after 5-10 minutes.
    When I restart MySQL, no errors happened. Falko think that: this error belong to another service out of mysql?

    This is /var/log/mysqld.log:
     
    Last edited: Nov 26, 2009
  9. mxtdn

    mxtdn New Member

    30 minutes ago, this situation happened again and I try not to restart mysql. I tried to connect by http://IP/phpmyadmin/. It display that: too many connections.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    You can raise the max. amount of connections with the max_connections setting in your my.cnf, e.g.
    Code:
    max_connections = 1000
    Restart MySQL afterwards.
     
  11. mxtdn

    mxtdn New Member

    Dear Falko

    Thanks Falko,

    /etc/my.conf
    Idon't find "max_connections". Could you please tell me ?!
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Add it to the [mysqld] section.
     
  13. mxtdn

    mxtdn New Member

    thank you very much !
     

Share This Page