mysql and unicode

Discussion in 'Server Operation' started by durjoy, Nov 12, 2007.

  1. durjoy

    durjoy New Member

    dear experts , i was hosting my site with diffrent hosting than current , however recently i have moved my site into new server . i have backed up sql file and uploaded into new server everything working fine but i have noticed unicode language isnt working with new database anymore . i have checked every single table all of them utf-8 multilingual uncode as it was in my old database . i couldnt figure out the problem . is there any setting i have to change to get mysql to support unicode . please help me .

    thanks

    regards

    niz
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Try this:
    Code:
    mysql_query('set character set utf8;');
     
  3. durjoy

    durjoy New Member

    accept my apologies for stupid questions ..

    should i run it on sql query
     
  4. durjoy

    durjoy New Member

    dear falko when i try to run this from .. sql .. i got this


    SQL query:

    mysql_query(

    'set character set utf8;'
    )

    MySQL said:

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'mysql_query('set character set utf8;')' at line 1
     
  5. James E

    James E New Member

    MySql

    Hello, experts,
    I have been following the tutorial The Perfect Setup - Ubuntu Feisty Fawn (Ubuntu 7.04). I have got ot page 4, when I'm enter the command "netstat -tap" mysql is not on the list:[email protected]:/home/server1# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 server1.local:domain *:* LISTEN 4819/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 4819/named
    tcp 0 0 localhost.localdoma:ipp *:* LISTEN 4871/cupsd
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 4819/named
    tcp 0 0 server1.local:53025 nf-in-f164.google.c:www ESTABLISHED5539/firefox-bin
    tcp 0 0 server1.local:59706 nf-in-f147.google.c:www ESTABLISHED5539/firefox-bin
    tcp 0 0 server1.local:53024 nf-in-f164.google.c:www ESTABLISHED5539/firefox-bin
    tcp6 0 0 *:domain *:* LISTEN 4819/named
    tcp6 0 0 *:ssh *:* LISTEN 4844/sshd
    tcp6 0 0 ip6-localhost:953 *:* LISTEN 4819/named
    [email protected]:/home/server1#

    It would be great if you could help me with this thanks,
    I have been trying to create a webserver for ages but I cannot do it, please help!!

    Thanks,
    James
     
  6. falko

    falko Super Moderator ISPConfig Developer

    I'm sorry - should have been
    Code:
    set character set utf8;
    only...
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Hi James,

    please open a new thread for this.
     
  8. durjoy

    durjoy New Member

    dear falko i have tried it but it doesnt work . i meant still i cant see unicode characters .. sorry
     

Share This Page