MySQL access from % and localhost

Discussion in 'Server Operation' started by TomTom80, Aug 8, 2007.

  1. TomTom80

    TomTom80 New Member

    Hi folks,

    I have little troubles with my MySQL, I have never seen it and I cannot google it.

    If I set some MySQL user access from host "%" he cannot log in from localhost. MySQL version is 5.0.37, Fedora 7.

    Is it exist some another wildcart which includes all and localhost? or is it some option which enables that "%" includes localhost too?


    Thanks all

    Tom
     
  2. geekman

    geekman New Member

    Well you could always just make another "user" for localhost which is identified by the same password. Then that will pretty much cover it all...odd though that the wildcard wouldn't cover localhost, though adding the second entry should work.

    Thanks.
     
  3. TomTom80

    TomTom80 New Member

    It works

    Yes, this works but I am confused why % doesn't include localhost.:confused: When I check runnig proccesses there is host localhost.

    It could be, that my local access skip TCP connection???

    Tom
     
  4. geekman

    geekman New Member

    Could you post the output of netstat -tap and your MySQL config file please?
     
  5. TomTom80

    TomTom80 New Member

    My outputs

    My netstat -tap
    Code:
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name   
    tcp        0      0 localhost.localdomain:2208  *:*                         LISTEN      2098/hpiod          
    tcp        0      0 *:imaps                     *:*                         LISTEN      2320/dovecot        
    tcp        0      0 *:pop3s                     *:*                         LISTEN      2320/dovecot        
    tcp        0      0 localhost.localdomain:smux  *:*                         LISTEN      2120/snmpd          
    tcp        0      0 *:mysql                     *:*                         LISTEN      2275/mysqld         
    tcp        0      0 *:pop3                      *:*                         LISTEN      2320/dovecot        
    tcp        0      0 *:distinct                  *:*                         LISTEN      3112/perl           
    tcp        0      0 *:imap                      *:*                         LISTEN      2320/dovecot        
    tcp        0      0 *:sunrpc                    *:*                         LISTEN      1902/rpcbind        
    tcp        0      0 *:http                      *:*                         LISTEN      2864/httpd          
    tcp        0      0 *:hosts2-ns                 *:*                         LISTEN      2836/ispconfig_http 
    tcp        0      0 *:ftp                       *:*                         LISTEN      3032/proftpd: (acce 
    tcp        0      0 localhost.localdomai:domain *:*                         LISTEN      3004/named          
    tcp        0      0 *:ssh                       *:*                         LISTEN      2140/sshd           
    tcp        0      0 localhost.localdomain:ipp   *:*                         LISTEN      2155/cupsd          
    tcp        0      0 localhost.localdomain:rndc  *:*                         LISTEN      3004/named          
    tcp        0      0 *:smtp                      *:*                         LISTEN      2943/master         
    tcp        0      0 *:https                     *:*                         LISTEN      2864/httpd          
    tcp        0      0 *:55966                     *:*                         LISTEN      1929/rpc.statd      
    tcp        0      0 localhost.localdomain:2207  *:*                         LISTEN      2103/python         
    and my.cnf
    Code:
    [mysqld_safe]
    log-error=/var/log/mysqld.log
    pid-file=/var/run/mysqld/mysqld.pid
    
    # Example MySQL config file for large systems.
    #
    # This is for a large system with memory = 512M where the system runs mainly
    # MySQL.
    #
    # You can copy this file to
    # /etc/my.cnf to set global options,
    # mysql-data-dir/my.cnf to set server-specific options (in this
    # installation this directory is /var/lib/mysql) or
    # ~/.my.cnf to set user-specific options.
    #
    # In this file, you can use all long options that a program supports.
    # If you want to know which options a program supports, run the program
    # with the "--help" option.
    
    # The following options will be passed to all MySQL clients
    [client]
    #password	= your_password
    port		= 3306
    socket		= /var/lib/mysql/mysql.sock
    
    # Here follows entries for some specific programs
    
    # The MySQL server
    [mysqld]
    datadir=/var/lib/mysql
    user=mysql
    # Default to using old password format for compatibility with mysql 3.x
    # clients (those using the mysqlclient10 compatibility package).
    old_passwords=0
    
    port		= 3306
    socket		= /var/lib/mysql/mysql.sock
    skip-locking
    key_buffer = 256M
    max_allowed_packet = 1M
    table_cache = 256
    sort_buffer_size = 1M
    read_buffer_size = 1M
    read_rnd_buffer_size = 4M
    myisam_sort_buffer_size = 64M
    thread_cache_size = 8
    query_cache_size= 16M
    # Try number of CPU's*2 for thread_concurrency
    thread_concurrency = 6
    
    #default-character-set=cp1250
    default-character-set=utf8
    flush_time=1800
    language=/usr/share/mysql/czech/
    
    
    # Don't listen on a TCP/IP port at all. This can be a security enhancement,
    # if all processes that need to connect to mysqld run on the same host.
    # All interaction with mysqld must be made via Unix sockets or named pipes.
    # Note that using this option without enabling named pipes on Windows
    # (via the "enable-named-pipe" option) will render mysqld useless!
    # 
    #skip-networking
    
    # Replication Master Server (default)
    # binary logging is required for replication
    log-bin=mysql-bin
    
    # required unique id between 1 and 2^32 - 1
    # defaults to 1 if master-host is not set
    # but will not function as a master if omitted
    server-id	= 1
    
    # Replication Slave (comment out master section to use this)
    #
    # To configure this host as a replication slave, you can choose between
    # two methods :
    #
    # 1) Use the CHANGE MASTER TO command (fully described in our manual) -
    #    the syntax is:
    #
    #    CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
    #    MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
    #
    #    where you replace <host>, <user>, <password> by quoted strings and
    #    <port> by the master's port number (3306 by default).
    #
    #    Example:
    #
    #    CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
    #    MASTER_USER='joe', MASTER_PASSWORD='secret';
    #
    # OR
    #
    # 2) Set the variables below. However, in case you choose this method, then
    #    start replication for the first time (even unsuccessfully, for example
    #    if you mistyped the password in master-password and the slave fails to
    #    connect), the slave will create a master.info file, and any later
    #    change in this file to the variables' values below will be ignored and
    #    overridden by the content of the master.info file, unless you shutdown
    #    the slave server, delete master.info and restart the slaver server.
    #    For that reason, you may want to leave the lines below untouched
    #    (commented) and instead use CHANGE MASTER TO (see above)
    #
    # required unique id between 2 and 2^32 - 1
    # (and different from the master)
    # defaults to 2 if master-host is set
    # but will not function as a slave if omitted
    #server-id       = 2
    #
    # The replication master for this slave - required
    #master-host     =   <hostname>
    #
    # The username the slave will use for authentication when connecting
    # to the master - required
    #master-user     =   <username>
    #
    # The password the slave will authenticate with when connecting to
    # the master - required
    #master-password =   <password>
    #
    # The port the master is listening on.
    # optional - defaults to 3306
    #master-port     =  <port>
    #
    # binary logging - not required for slaves, but recommended
    #log-bin=mysql-bin
    
    # Point the following paths to different dedicated disks
    #tmpdir		= /tmp/		
    #log-update 	= /path-to-dedicated-directory/hostname
    
    # Uncomment the following if you are using BDB tables
    #bdb_cache_size = 64M
    #bdb_max_lock = 100000
    
    # Uncomment the following if you are using InnoDB tables
    #innodb_data_home_dir = /var/lib/mysql/
    #innodb_data_file_path = ibdata1:10M:autoextend
    #innodb_log_group_home_dir = /var/lib/mysql/
    #innodb_log_arch_dir = /var/lib/mysql/
    # You can set .._buffer_pool_size up to 50 - 80 %
    # of RAM but beware of setting memory usage too high
    #innodb_buffer_pool_size = 256M
    #innodb_additional_mem_pool_size = 20M
    # Set .._log_file_size to 25 % of buffer pool size
    #innodb_log_file_size = 64M
    #innodb_log_buffer_size = 8M
    #innodb_flush_log_at_trx_commit = 1
    #innodb_lock_wait_timeout = 50
    
    [mysqldump]
    quick
    max_allowed_packet = 16M
    
    [mysql]
    no-auto-rehash
    # Remove the next comment character if you are not familiar with SQL
    #safe-updates
    
    [isamchk]
    key_buffer = 128M
    sort_buffer_size = 128M
    read_buffer = 2M
    write_buffer = 2M
    
    [myisamchk]
    key_buffer = 128M
    sort_buffer_size = 128M
    read_buffer = 2M
    write_buffer = 2M
    
    [mysqlhotcopy]
    interactive-timeout
    
     
  6. geekman

    geekman New Member

    Hmmm, that is puzzling, have you tried connecting from 127.0.0.1, maybe it just doesn't like the fact that that's a hostname *shrug* I'll have to look into this a little.

    Thanks.
     
  7. TomTom80

    TomTom80 New Member

    Idea

    Could be in my /etc/hosts?

    Code:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1	localhost.localdomain	localhost	golias
    195.47.7.1	golias.domain.cz
    ::1	localhost6.localdomain6	localhost6 
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Can you try and move the golias to the 195.47.7.1 line in /etc/hosts?

    Also, did you restart MySQL or run a
    Code:
    FLUSH PRIVILEGES;
    after your changes to the mysql.user table?
     
  9. TomTom80

    TomTom80 New Member

    Bad news

    Hi Falko,

    I tried this change
    Code:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1	localhost	
    195.47.7.1	golias.domain.cz golias
    ::1	localhost6.localdomain6	localhost6 
    bad it doesn't work :(

    I tried restart whole server bad nothing happed.

    Before save it asked me that there is hardlink ... a didn't brake it.

    Tom
     
  10. falko

    falko Super Moderator ISPConfig Developer

    You've removed localhost.localdomain from the 127.0.0.1 line. Please put it back in.
     
  11. TomTom80

    TomTom80 New Member

    Hi Falko,

    I tried it yesterday, but I wasn't sure .... I have placed it back, but same result .... % doesn't include localhost :(

    I'm very desperate
     
  12. falko

    falko Super Moderator ISPConfig Developer

    I'm always having one record for localhost and one record for % in my mysql.user table. Try to add a seperate record for localhost.
     
  13. TomTom80

    TomTom80 New Member

    Hi Falko,

    this configuration works I tried it at first, but all previous installations of MySQL run with only one row and this row include localhost.
    Do you mean, that have two rows is right way?

    Tom
     
  14. falko

    falko Super Moderator ISPConfig Developer

    At least it isn't wrong. i'm doing it like that myself and never had any problems. :)
     

Share This Page