MySQL 5.0.38 installation problem

Discussion in 'Installation/Configuration' started by bastijn, Apr 14, 2007.

  1. bastijn

    bastijn New Member

    Hi all,

    I updated/upgraded my server yesterday. It runs on Debian Sarge.
    The last time I have updated my server was about 2 weeks ago. So that aint so long ago.
    While updating, Debian found the new MySQL (mysql-server-5.0.38), but during installing it doesn't complete and gets stuck. I have tried to get it to work again for about 2 hours, then a friend of mine tried, both with no result.

    This is happening:
    Setting up mysql-server-5.0 (5.0.38-1) ...
    Stopping MySQL database server: mysqld

    Then it does nothing....
    So after 10 minutes i pressed ctrl + c and tried again, and again....
    Then i tried apt-get remove, purge, dpkg, etc etc etc...

    Can somebody please help me??

    Greetz,
    Bastijn
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in your /etc/apt/sources.list?
    I guess your Sarge tried to install MySQL packages from "stable" which is now Etch. Maybe the Etch packages don't work on Sarge.
     
  3. bastijn

    bastijn New Member

  4. kumy

    kumy New Member

    Hi all,

    exactly the same problem here...

    Code:
    cat /etc/apt/sources.list
    deb ftp://mir1.ovh.net/debian/ testing main
    deb-src ftp://mir1.ovh.net/debian/ testing main
    deb http://security.debian.org/ testing/updates main
    
    deb http://secure-testing.debian.net/debian-secure-testing etch/security-updates main contrib non-free
    deb-src http://secure-testing.debian.net/debian-secure-testing etch/security-updates main contrib non-free
    bastijn> did you find a solution ?

    Regards
    Mât
     
  5. bastijn

    bastijn New Member

    I am glad I'm not the only one with this problem. No I still haven't found a solution, I really don't understand what is wrong.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Since April 8, etch isn't testing anymore. Etch is the new stable version, and lenny is now testing. That's why your systems try to download lenny packages instead of etch packages. You should replace all occurrences of testing with etch in your /etc/apt/sources.list. Run
    Code:
    apt-get update
    afterwards.
     
  7. kumy

    kumy New Member

  8. bastijn

    bastijn New Member

    This one worked for me too, thanks alot :D

    Grtz,
    Bastijn
     
  9. mvp

    mvp New Member

    i have the same problem with mysql, but that solution dosent help me a bit.

    i replace testing with etch and run apt-get update which is fine.
    then when i try to eith apt-get install mysql-server-5.0 or remove or --fix-broken it still hangs with
    Setting up mysql-server-5.0 (5.0.38-1) ...
    Stopping MySQL database server: mysqld

    any ideas appriciated, this is very annoying

    okay. after spending way too much time on this if finaly got it removed. not really sure how, tried a bunch of stuff. think it was because i deleted /var/run/mysqld and then i was able to run apt-get remove mysql-server-5.0 without any problems
     
    Last edited: Apr 19, 2007
  10. bastijn

    bastijn New Member

    After replacing testing with etch you first have to purge mysql-server-5.0
    Because etch can not handle the 5.0.38 version, but has the 5.0.32 version.
    After purging, do apt-get install mysql-server-5.0
    Then it will be fine again.
     
  11. Leszek

    Leszek New Member

    Hi!

    It seems that my problem is similar.
    Yesterday I've installed Debian Etch netinstall according to the Perfect Setup and stopped on step 10 - MySQL.Everything stops durring the configuration of the MySQL-server package.The server cannot be started or stopped.
    /etc/init.d/mysql start or stop works.
    My /etc/apt/sources.list contains:
    Code:
    # 
    # deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 NETINST Binary-1 20070407-11:29]/ etch contrib main
    
    # deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 NETINST Binary-1 20070407-11:29]/ etch contrib main
    
    deb http://ftp.pl.debian.org/debian/ etch main
    deb-src http://ftp.pl.debian.org/debian/ etch main
    
    deb http://security.debian.org/ etch/updates main contrib
    deb-src http://security.debian.org/ etch/updates main contrib
    
    After I finally stop it by hand (ctrl-c or z) and try to reconfigure it (apt-get reconfigure mysql-server) it complains that some file is locked and it can't reconfigure the package that I stopped.
    This problem comes from time to time in some packages and I don't know how to deal with it.
    Can anyone help ? Thanks in advance.
     
    Last edited: Apr 23, 2007
  12. falko

    falko Super Moderator ISPConfig Developer

    What's the exact error message?
     
  13. Leszek

    Leszek New Member

    Sorry for the delay.
    Like I described earlier I see:
    ... and saw:

    The above text is a translation of original error messages from Polish
    It also happens after changing repositories in /etc/apt/sources.list and typing the ones from Falko's perfect setup howto.
    I couldn't wait forever for it to finish but what now ?

    When I type dpkg-reconfigure mysql-server I get:

    /usr/sbin/dpkg-reconfigure: mysql-server is corrupt or is not fully installed.
    The same with dpkg-reconfigure mysql-server-5.0

    Problems like this occur from time to time with other packages.
    Then when I try to dpkg-reconfigure package_name I get an error telling me that some file is locked and it couldn't be reconfigured.I can't remember the exact message now.
     
  14. falko

    falko Super Moderator ISPConfig Developer

    That's really strange.
    In that case you should consider a clean re-install because I think you won't have much fun with the current system...
     
  15. Leszek

    Leszek New Member

    It happened a coupple of times before,even on Debian Sarge with Midnight Commander.
    It's a good thing that now I can afford to reinstall.
     

Share This Page