MyDNS

Discussion in 'General' started by Dextros, Nov 11, 2010.

  1. Dextros

    Dextros New Member HowtoForge Supporter

    Evening Folks

    Im having some bad problems :)

    I cannot get MyDNS to start i keep getting this error:


    Starting mydns: mydns[12314]: Error connecting to MySQL server at localhost: Access denied for user 'ispconfig'@'localhost' (using password: YES) (errno=0)

    here is SQL log

    101111 17:54:22 InnoDB: Starting shutdown...
    101111 17:54:23 InnoDB: Shutdown completed; log sequence number 0 43705
    101111 17:54:23 [Note] /usr/libexec/mysqld: Shutdown complete

    101111 17:54:23 mysqld ended

    101111 17:54:23 mysqld started
    101111 17:54:23 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
    101111 17:54:23 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
    101111 17:54:23 InnoDB: Started; log sequence number 0 43705
    101111 17:54:23 [Note] /usr/libexec/mysqld: ready for connections.
    Version: '5.0.77' socket: '/var/lib/mysql/mysql.sock' port: 3306 Source distribution


    Her is my message log

    Nov 11 17:54:39 ks32703 mydns[11774]: Error connecting to MySQL server at localhost: Access denied for user 'ispconfig'@'localhost' (using password: YES) (errno=0)
    Nov 11 17:54:39 ks32703 named[3591]: shutting down: flushing changes
    Nov 11 17:54:39 ks32703 named[3591]: stopping command channel on 127.0.0.1#953
    Nov 11 17:54:39 ks32703 named[3591]: no longer listening on 127.0.0.1#53
    Nov 11 17:54:39 ks32703 named[3591]: no longer listening on 213.251.162.200#53
    Nov 11 17:54:39 ks32703 named[3591]: exiting
    Nov 11 17:54:41 ks32703 named[11819]: starting BIND 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.1 -u named
    Nov 11 17:54:41 ks32703 named[11819]: adjusted limit on open files from 1024 to 1048576
    Nov 11 17:54:41 ks32703 named[11819]: found 1 CPU, using 1 worker thread
    Nov 11 17:54:41 ks32703 named[11819]: using up to 4096 sockets
    Nov 11 17:54:42 ks32703 named[11819]: loading configuration from '/etc/named.conf'
    Nov 11 17:54:42 ks32703 named[11819]: using default UDP/IPv4 port range: [1024, 65535]
    Nov 11 17:54:42 ks32703 named[11819]: using default UDP/IPv6 port range: [1024, 65535]
    Nov 11 17:54:42 ks32703 named[11819]: no IPv6 interfaces found
    Nov 11 17:54:42 ks32703 named[11819]: listening on IPv4 interface lo, 127.0.0.1#53
    Nov 11 17:54:42 ks32703 named[11819]: listening on IPv4 interface eth0, 213.251.162.200#53
    Nov 11 17:54:42 ks32703 named[11819]: command channel listening on 127.0.0.1#953
    Nov 11 17:54:42 ks32703 named[11819]: the working directory is not writable
    Nov 11 17:54:42 ks32703 named[11819]: running
    Nov 11 17:59:32 ks32703 mydns[12314]: Error connecting to MySQL server at localhost: Access denied for user 'ispconfig'@'localhost' (using password: YES) (errno=0)
    Nov 11 18:04:37 ks32703 clamd[11673]: No stats for Database check - forcing reload


    I have uninstall, installed and updated allowing to reconfigure services on the updates.

    before i re did it all, i even went into mydns.conf and changed the database logon password from what was in the phpmyadmins table, which i had changed with "password" instead of MD5. This in theory should have been the same password and i still get this error.

    Please help

    Lee


    Edit;

    Ok i got it working buy following http://www.howtoforge.com:8080/installing-mydns-mydnsconfig-centos-5.1-p2


    Now the DNS is messed up,
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.1 <<>> lahtechnologies.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 12434
    ;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;lahtechnologies.com. IN A

    ;; Query time: 2 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Nov 11 22:42:09 2010
    ;; MSG SIZE rcvd: 37

    As you can see it should have a lot more info than that
     
    Last edited: Nov 11, 2010
  2. Ghostdare

    Ghostdare Member

    I see that you have installed BIND and MyDNS on your server, and i think that ISPConfig is using BIND, so start configure your zone in ISPConfig pannel.
     
  3. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    ISPConfig 3 supports both MyDNS and BIND.

    It seems as if BIND is already running. Can you post the output of
    Code:
    netstat -tap
    ?
     
  4. Dextros

    Dextros New Member HowtoForge Supporter

    Please find below;

    [root@ks32703 ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address Stat e PID/Program name
    tcp 0 0 *:imaps *:* LIST EN 3469/couriertcpd
    tcp 0 0 *:pop3s *:* LIST EN 3481/couriertcpd
    tcp 0 0 localhost.localdomain:10024 *:* LIST EN 5912/amavisd (maste
    tcp 0 0 localhost.loc:commplex-main *:* LIST EN 5250/rtorrent
    tcp 0 0 localhost.localdomain:10025 *:* LIST EN 27293/master
    tcp 0 0 *:mysql *:* LIST EN 3375/mysqld
    tcp 0 0 *:eek:penvpn *:* LIST EN 3193/openvpn
    tcp 0 0 *:pop3 *:* LIST EN 3475/couriertcpd
    tcp 0 0 localhost.local:dyna-access *:* LIST EN 3289/clamd
    tcp 0 0 *:imap *:* LIST EN 3462/couriertcpd
    tcp 0 0 *:webcache *:* LIST EN 3564/httpd
    tcp 0 0 *:http *:* LIST EN 3564/httpd
    tcp 0 0 *:tproxy *:* LIST EN 3564/httpd
    tcp 0 0 *:51026 *:* LIST EN 5250/rtorrent
    tcp 0 0 ks32703.kimsufi.com:domain *:* LIST EN 28745/named
    tcp 0 0 localhost.localdomai:domain *:* LIST EN 28745/named
    tcp 0 0 *:6933 *:* LIST EN 5231/rtorrent
    tcp 0 0 *:ftp *:* LIST EN 3578/pure-ftpd (SER
    tcp 0 0 *:ssh *:* LIST EN 3272/sshd
    tcp 0 0 localhost.localdomain:rndc *:* LIST EN 28745/named
    tcp 0 0 *:smtp *:* LIST EN 27293/master
    tcp 0 0 *:https *:* LIST EN 3564/httpd
    tcp 0 24226 ks32703.kimsufi.com:56732 119-224-76-251.callpl:57777 ESTA BLISHED 5250/rtorrent
    tcp 0 0 localhost.localdomain:mysql localhost.localdomain:52923 ESTA BLISHED 3375/mysqld
    tcp 0 163564 ks32703.kimsufi.com:51128 94.123.208.149:60000 ESTA BLISHED 5250/rtorrent
    tcp 0 1084 ks32703.kimsufi.com:ssh 5e006322.bb.sky.com:50902 ESTA BLISHED 6141/0
    tcp 0 499560 ks32703.kimsufi.com:52099 c-68-61-147-179.hsd1.:17482 ESTA BLISHED 5250/rtorrent
    tcp 0 0 localhost.localdomain:58948 localhost.localdomain:mysql ESTA BLISHED 5921/amavisd (ch9-a
    tcp 0 0 localhost.localdomain:mysql localhost.localdomain:58948 ESTA BLISHED 3375/mysqld
    tcp 0 0 localhost.localdomain:52923 localhost.localdomain:mysql ESTA BLISHED 5920/amavisd (ch10-
    tcp 0 65160 ks32703.kimsufi.com:39741 5e049167.bb.sky.com:29180 ESTA
     
  5. Dextros

    Dextros New Member HowtoForge Supporter

    Woot, its worki,g...to a fasion.

    Bind is not off and gone, mydns has taken over.

    Now, when i installed ispconfig (updated) it didnt merge with mydns.

    So what i have had to do is use the new database called mydns and import the data from rr and soa in mydns to that it works.

    Is there a way to do this automatically?
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please uninstall BIND. The next time you upgrade ISPConfig, the installer will see that you have MyDNS installed and configure ISPConfig accordingly.
     
  7. Dextros

    Dextros New Member HowtoForge Supporter

    Thank you for you help, unfortunately that did not solve the problem,

    When i point mydns to dbispconfig data base it gives the following error,


    Starting mydns: mydns[2805]: Required table `soa' in database `dbispconfig' not found or inaccessible
    mydns[2805]: Do you need to create the tables in the `dbispconfig' database?
    mydns[2805]: You can run `mydns --create-tables' to output appropriate SQL commands


    Copy of mydns.conf


    ## /etc/mydns.conf


    # DATABASE INFORMATION

    db-host = localhost # SQL server hostname
    db-user = root # SQL server userna
    db-password = christian1 # SQL server password
    database = mydns # MyDNS database name


    # GENERAL OPTIONS

    user = nobody # Run with the permissions of this user
    group = nogroup # Run with the permissions of this group
    listen = * # Listen on these addresses ('*' for all)


    # CACHE OPTIONS

    zone-cache-size = 1024 # Maximum number of elements stored in the zone cache
    zone-cache-expire = 60 # Number of seconds after which cached zones expires
    reply-cache-size = 1024 # Maximum number of elements stored in the reply cache
    reply-cache-expire = 30 # Number of seconds after which cached replies expire

    :
    # ESOTERICA

    log = LOG_DAEMON # Facility to use for program output (LOG_*/stdout/stderr)
    pidfile = /var/run/mydns.pid # Path to PID file
    timeout = 120 # Number of seconds after which queries time out
    multicpu = 1 # Number of CPUs installed on your system
    allow-axfr = no # Should AXFR be enabled?
    allow-tcp = yes # Should TCP be enabled?
    ignore-minimum = no # Ignore minimum TTL for zone?
    soa-table = soa # Name of table containing SOA records
    rr-table = rr # Name of table containing RR data
     
    Last edited: Nov 13, 2010
  8. Dextros

    Dextros New Member HowtoForge Supporter

    I swear im not trying to annoy you guys :)

    I cant seem to load php pages under peoples account.

    Any clues?
     
  9. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    The tables are named dns_soa and dns_rr.


    Any errors in Apache's error log?
    Which PHP mode do you use?
     
  10. Dextros

    Dextros New Member HowtoForge Supporter

    Hi Falko, i know thats what they are called, but the update.php doesnt seem to be updating mydns.

    Is there a way i can tall it to look for the tables in dbispconfig rather than it looking for standard soa and rr?

    Also no errors in apache, but im still working on figuring that out.
     
  11. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You must modify /etc/mydns.conf. Fill in the correct database user and password and the ISPConfig database and also the correct table names, then restart MyDNS.
     

Share This Page