MyDNS won't start at boot SQUEEZE

Discussion in 'General' started by hosler, Jun 9, 2011.

  1. hosler

    hosler New Member

    Hello. I installed MyDNS + MyDNSconfig using the debian squeeze tutorial on this site. Everything works except that mydns will not start on boot. I read a few threads and updated my init scripts, but it still won't boot. Below is what I added to the init scripts of mydns and bastille-firewall. Perhaps I am missing something?

    mydns
    Code:
    ### BEGIN INIT INFO
    # Provides:          scriptname
    # Required-Start:    $remote_fs $syslog
    # Required-Stop:     $remote_fs $syslog
    # Default-Start:     2 3 4 5
    # Default-Stop:      0 1 6
    # Short-Description: Start daemon at boot time
    # Description:       Enable service provided by daemon.
    ### END INIT INFO
    
    bastille-firewall
    Code:
    ### BEGIN INIT INFO
    # Provides:          bastille-firewall
    # Required-Start:    $network
    # Required-Stop:     $network
    # Default-Start:     S
    # Default-Stop:      0 6
    # Short-Description: Load/unload ipchains rulesets
    # Description:       A firewall/packet-filter script for Linux systems
    #                    that allows the machine to be used as a gateway system
    ### END INIT INFO
    
    i am not using ispconfig.

    thanks in advance
     
  2. atjensen11

    atjensen11 New Member

    This is the block I added to /etc/init.d/mydns which ultimately fixed my bootup script order so that MyDNS would start correctly.

    Code:
    ### BEGIN INIT INFO
    # Provides:          mydns
    # Required-Start:    mysql
    # Required-Stop:     mysql
    # Default-Start:     2 3 4 5
    # Default-Stop:      0 1 6
    # Short-Description: Start daemon at boot time
    # Description:       Enable service provided by daemon.
    ### END INIT INFO
    
    After editing /etc/init.d/mydns, rerun the following command:

    Code:
    update-rc.d mydns defaults
    
     

Share This Page