MyDNS to Bind on CentOS 5.4 x64

Discussion in 'Installation/Configuration' started by Nicram, Jun 3, 2010.

  1. Nicram

    Nicram New Member

    I'm using CentOS 5.4 64bit, i have found that there is problem with MyDNS (transfer data to seconrady DNS). I try to install MyDNS-NG but it donot support 64bit mysql-devel i think (it is error when make).

    So i back to my old love - bind (i'm get used to it a little bit because i use openbsd and it is there rock solid with nice chroot).

    The question is how to make it work.
    First what i have found is info in the archive with ispconfig - /docs/INSTALL_CENTOS_5.4_dovecot_bind.txt.

    So i made every step from that file, but i think something may be wrong there (last step do not work, because bind is searching for file, that is not made with steps, so i made file myself - named.conf.local).

    After that named start to work.
    Then i made changes in ispconfig control panel, in system->services->dns (i put correct path to the files there), after that i made "manual update" from here: http://www.howtoforge.com/forums/showthread.php?t=44277.
    And here are the questions now:
    How to make old DNS entries from ispconfig work with new DNS server?
    Will ISPConfig automatically generate correct files for named, or do i have to make them myself from null?
    How can i know that ISPConfig noticed change of DNS server and start to work with it. and if there are problems connecting ISPConfig with new DNS server app, where can i find logs for that?
    Thanks for any answer :)
     
    Last edited: Jun 3, 2010
  2. Rapid2214

    Rapid2214 New Member

    Could you post the output of 'ls' or 'dir' from your bind directory?

    Thanks

    Marty
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Bind has to be installed before you install ispconfig or at least the services have to be reconfigured.

    Download the ispconfig tar,gz file. Run the update.php script in the install folder and select to reconfigure services.

    BIND is file based, so aold records dont get written to bind files. Only new and changed records will get written.

    See in Ispconfig > Monitor > system log

    This file ahs not to be created manually as it is created by ispconfig.
     
  4. Nicram

    Nicram New Member

    Hello and thank You for anstwers! :)


    Code:
    # cd /var/named/
    # ls -a
    .  ..  chroot  data  slaves
    # cd chroot/
    # ls -a
    .  ..  dev  etc  proc  var
    # cd etc
    # ls -a
    .  ..  localtime  named.conf  named.conf.local  rndc.key
    # cd ..
    # cd var
    # ls -a
    .  ..  log  named  run  tmp
    # cd named
    # ls -a
    .  ..  chroot  data  named.local  named.root  slaves
    
    Well i did that already, i did manual update with services reconfiguration, i said that :)

    Isn't that same what can i find in /var/log/messages ?
    I'm asking if ISPConfig make log of it's own operations. For example when i make new DNS zone, when can i find if the file were made fine, or there was error, or when add new user, when can i find what changes ISPConfig did in the system?

    Then please correct /docs/INSTALL_CENTOS_5.4_dovecot_bind.txt file, because it asks to run BIND without that file, and it will not work without it, and people like me do not know if it;s good or bad, and why.

    Best Regards

    Update:
    My system->DNS settings are:
    BIND user: root
    BIND Group: named (there is no user or group "bind" in the system)
    BIND zonefiles directory: /var/named/chroo/var/named
    BIND named.conf path: /var/named/chroo/etc/named.conf
    /var/named/chroo/etc/named.conf.local
     
    Last edited: Jun 3, 2010
  5. Nicram

    Nicram New Member

    Please anyone help :)
    How to make named working with ispconfig on centos 5.4 x64.
    Did anyone try this and get working?
    Can anyone tell me steps one by one?
     
  6. Nicram

    Nicram New Member

    I enabled DEBUG mode, and it helped a lot.
    I did have typo in the path settings.
    Well i fixed it and now there is another problem.
    I changed some DNS zones and ispconfig generate all files, but:
    1) there was no allow transfer in named.conf.local
    and i have find out that someone create dns zone, but without any data in it, so i deleted this dns zone and... named wasn;t refreshed anymore.
    I enabled DEBUG mode again and what i have found was:

    2010-06-04 14:22 hosting.xxx.de Debug There is already a lockfile set. Waiting another 10 seconds...
    2010-06-04 14:22 hosting.xxx.de Debug There is already a lockfile set. Waiting another 10 seconds...
    2010-06-04 14:22 hosting.xxx.de Debug There is already a lockfile set. Waiting another 10 seconds...
    2010-06-04 14:22 hosting.xxx.de Debug There is already an instance of server.php running. Exiting.
    2010-06-04 14:21 hosting.xxx.de Debug There is already a lockfile set. Waiting another 10 seconds...
    2010-06-04 14:21 hosting.xxx.de Debug There is already a lockfile set. Waiting another 10 seconds...
    2010-06-04 14:21 hosting.xxx.de Debug There is already a lockfile set. Waiting another 10 seconds...

    So what i have made was:
    # rm -f /usr/local/ispconfig/server/temp/.ispconfig_lock && /usr/bin/php -q /usr/local/ispconfig/server/server.php
    04.06.2010-14:18 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    04.06.2010-14:18 - DEBUG - Found 8 changes, starting update process.
    04.06.2010-14:18 - DEBUG - Call function 'soa_delete' in plugin 'bind_plugin' raised by event 'dns_soa_delete'.
    #

    What to do next? I think it cannot delete SOA from file or something?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats a bug which has been fixed already in SVN. Download the latest version from SVN version and copy only the file server/plugins-available/bind_plugin.inc.php to /usr/local/ispconfig/server/plugins-available/
     
  8. Nicram

    Nicram New Member

    Thanks, now it started to work, but still no allow-transfer in named.conf.local.
    For example:
    Code:
    zone "somedomain.tld" {
            type master;
            file "/var/named/chroot/var/named/pri.somedomain.tld";
    };
    I think there should be
    Code:
    zone "somedomain.tld" {
            type master;
            file "/var/named/chroot/var/named/pri.somedomain.tld";
            allow-transfer { 123.123.123.123; };
            notify yes;
    
    };
    How can i fix this? Without that there is error like:
    Jun 4 16:17:30 hosting named[12465]: client 123.123.123.123#4987: query 'somedomain.tld/SOA/IN' denied

    Some TIP for any other that will read it.
    Add port 953 in firewall settings of ISPConfig, without it
    # /etc/init.d/named status
    rndc: connect failed: 127.0.0.1#953: connection refused
     
  9. Nicram

    Nicram New Member

    The problem was another documentation mistake (file INSTALL_CENTOS_5.4_dovecot_bind.txt).

    There is info what to paste into the named.conf file, and there is line:
    [code[ allow-query { localhost; };[/code].
    It is blocking connection between anything (like secondary dns or any dns queries from outside). After i excluded this line in config files, it started to work correctly.
    Well i still think it should use notify and allow transfer options, but at least it works :)
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Notify and transfer is only implementde for mydns. It will get implemented for bind in the next ispconfig release.
     

Share This Page