MyDns shows errors offline under monitoring

Discussion in 'Installation/Configuration' started by icompany, Dec 15, 2009.

  1. icompany

    icompany New Member

    MyDns shows errors offline under monitoring tab in ispconfig. Not sure if this is up and running correctly?


    Code:
    Directory: /
    Tue Dec 15 13:19:02 EST 2009
    s5780003:/ # chmod 755 /etc/init.d/mydns
    s5780003:/ # cd /etc/init.d
    s5780003:/etc/init.d # chkconfig --add mydns
    insserv: Script stor_agent is broken: incomplete LSB comment.
    insserv: missing `Provides:' entry: please add.
    insserv: Script stor_agent is broken: incomplete LSB comment.
    insserv: missing `Provides:' entry: please add.
    insserv: Script stor_agent is broken: incomplete LSB comment.
    insserv: missing `Provides:' entry: please add.
    insserv: Script stor_agent is broken: incomplete LSB comment.
    insserv: missing `Provides:' entry: please add.
    insserv: warning: script 'bastille-firewall' missing LSB tags and overrides
    insserv: Default-Start undefined, assuming default start runlevel(s) for script `bastille-firewall'
    insserv: Script stor_agent is broken: incomplete LSB comment.
    insserv: missing `Provides:' entry: please add.
    mydns                     0:off  1:off  2:off  3:off  4:off  5:off  6:off
    s5780003:/etc/init.d # 
    
    
    
     
    Last edited: Dec 15, 2009
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    netstat -tap | grep dns
     
  3. icompany

    icompany New Member

    Code:
    Directory: /
    Wed Dec 16 17:23:34 EST 2009
    s5780003:/ # netstat -tap | grep dns
    s5780003:/ # chkconfig --list mydns on
    mydns                     0:off  1:off  2:off  3:off  4:off  5:off  6:off
    on: unknown service
    s5780003:/ # 
    
    do I need to go into services and start?
     
  4. icompany

    icompany New Member

    i restarted mydns from gnome services. seems to be working now.


    1) after the install is complete how can I tell if everything is funtioning ok website mail dns firewall?

    2) my setup is through a cable modem broadband - router- then server. I have the router setup with the isp static ip and the server setup with the static ip from the router I assigned. Which static iP should be used for the dns setup? I used the one from the router

    Thanks
     
    Last edited: Jan 9, 2010
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Create a website and email domain and test if it works.
    2) In dns you use the external ip, in website settings you use the internal ip.
     
  6. icompany

    icompany New Member

    sorry new to linux, I created a website under ispconfig, where are the files located (etc/apache/htdocs) ? Does it auto create a index.htm as the default page ? I also set the mail under ispconfig. How do I test both?

    Thanks,
     
  7. icompany

    icompany New Member

    Mydns has to be restarted after every reboot.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use?
     
  9. icompany

    icompany New Member

    ispconfig 3.0.1.6 opensuse 11.2
     
  10. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    chkconfig --list | grep mydns
    ?
     
  11. icompany

    icompany New Member

    Well I just rebooted and it seems to be on. I have another thread in for mydns not resolving hostname or domain name. I think I may need to reinstall ispconfig and mydns. I had changed the locaL domain name and deleted the original dns zone and recreated and this is when problems started arising? Ihave another threa din for how to uninstall ispconfig / mydns

    Code:
    Directory: /
    Sat Dec 19 14:15:14 EST 2009
    s5780003:/ # chkconfig --list | grep mydns
    mydns                     0:off  1:off  2:on   3:on   4:off  5:on   6:off
    s5780003:/ # 
    
    
    Thanks for all your help
     

Share This Page