MyDNS notify problem

Discussion in 'Installation/Configuration' started by sgabor, Dec 20, 2011.

  1. sgabor

    sgabor New Member

    Hi there,

    I have a small but annoying problem, and I can't find any solution for this.
    I have ISPConfig Version: installed system with MyDNS (mydns (mydns) (MySQL 5.1.41)) on Ubuntu 10.04 (32bit) - Linux 2.6.32-37-generic-pae #81-Ubuntu SMP Fri Dec 2 22:24:22 UTC 2011 i686 GNU/Linux.

    The problem is when I setting up a new DNS domain in ISPconfig interface, that it generated without problem, but the secondary DNS system isn't notified, and also the new domain isn't created.
    In the 2nd. system I tried to find the problem, but I can't find anything in the logs. It looks no package sent from main server to 2nd server.

    I already enabled allow-update, allow-axfr, notify-enabled and notify-source options in /etc/mydns.conf.
    For debugging I changed the log facility to logging to a file (/var/log/mydsn.log). In the log file I find these lines:
    Sorry for Hungarian words, I translated for you:
    "Érvénytelen argumentum" means Invalid arguments
    So I think the problem is
    but I don't know how to sole this.
    In log entries the address is the secondary server.

    I tried to reinstall the mydns service and after reinstall updated the ISPconfig to reconfigure services, but no luck... :mad:

    This system is a live system, and I installed about 1,5 years ago.

    I attached the file with contain ipchains rules, mydns.conf.txt and mydns.log.txt.

    Please help me to solve this problem.

    Thanks a lot...


    Attached Files:

  2. falko

    falko Super Moderator ISPConfig Developer

    Do you also use MyDNS on the slave? Is the slave an ISPConfig mirror, or is there no ISPConfig on that system?
  3. sgabor

    sgabor New Member

    hi falko,

    The 2nd. DNS system is powerdns, and this is not a mirror. Just only a simple CentOS system in the world. It's already configured to accept any communcation over TCP and UDP port 53 from my ISPconfig system (MyDNS).


    Merry X-Mass

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Mydns can not notify another system for dns changes, for that reason we switched to bind as default dns system in ispconfig. You should consider to replace mydns with bind or as alternative you use the ispconfig dns server mirroring features which would require to install ispconfig on the seconfdary dns too as slave server and let ispconfig configure powerdns.
  5. sgabor

    sgabor New Member

    hi till,

    Thanks a quick reply. :)
    I'm not happy whit this, but I have to accept, and I will reconfigure the system with bind.

    Thhaks a lot, again...

    Merry X-Mass.


Share This Page