MyDNS is stopped

Discussion in 'General' started by Ventzy, Jun 25, 2010.

  1. Ventzy

    Ventzy New Member

    This morning I find out that MyDNS is stopped and sites doesnt work. I started it with /etc/init.d/mydns start and its working fine now.

    How to find what was caused stopping of MyDNS?

    I have no logs for mydns in /var/log.

    There is my /etc/init.d/mydns:
    Code:
    #! /bin/sh
    #
    # mydns         Start the MyDNS server
    #
    # Author:       Philipp Kern <phil@philkern.de>.
    #               Based upon skeleton 1.9.4 by Miquel van Smoorenburg
    #               <miquels@cistron.nl> and Ian Murdock <imurdock@gnu.ai.mit.edu>.
    #
    
    set -e
    
    PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
    DAEMON=/usr/local/sbin/mydns
    NAME=mydns
    DESC="DNS server"
    
    SCRIPTNAME=/etc/init.d/$NAME
    
    # Gracefully exit if the package has been removed.
    test -x $DAEMON || exit 0
    
    case "$1" in
      start)
            echo -n "Starting $DESC: $NAME"
            start-stop-daemon --start --quiet \
                    --exec $DAEMON -- -b
            echo "."
            ;;
      stop)
            echo -n "Stopping $DESC: $NAME"
            start-stop-daemon --stop --oknodo --quiet \
                    --exec $DAEMON
            echo "."
            ;;
      reload|force-reload)
            echo -n "Reloading $DESC configuration..."
            start-stop-daemon --stop --signal HUP --quiet \
                    --exec $DAEMON
            echo "done."
            ;;
      restart)
            echo -n "Restarting $DESC: $NAME"
            start-stop-daemon --stop --quiet --oknodo \
                    --exec $DAEMON
            sleep 1
            start-stop-daemon --start --quiet \
                    --exec $DAEMON -- -b
            echo "."
            ;;
      *)
            echo "Usage: $SCRIPTNAME {start|stop|restart|reload|force-reload}" >&2
            exit 1
            ;;
    esac
    
    exit 0
    And here is /etc/mydns.conf
    Code:
    ## AUTOMATICALLY GENERATED BY DEBCONF. DO NOT MODIFY DATABASE
    ## INFORMATION (database, db-*)...
    ## PLEASE RUN 'dpkg-reconfigure mydns-mysql' INSTEAD.
    ## CHANGES TO THE FOLLOWING DIRECTIVES ARE NOT PRESERVED, BUT REPLACED,
    ## ON UPGRADE:
    ##  user, group, pidfile, db-*, database
    
    ##
    ##  /etc/mydns.conf
    ##  Thu Aug  2 16:36:26 2007
    ##  For more information, see mydns.conf(5).
    ##
    
    
                                    # DATABASE INFORMATION
    
    db-host = localhost             # SQL server hostname
    db-user = ispconfig             # SQL server username
    db-password = [PASSWORD]         # SQL server password
    database = dbispconfig          # MyDNS database name
    
    
                                    # GENERAL OPTIONS
    
    user = nobody                   # Run with the permissions of this user
    group = nogroup                 # Run with the permissions of this group
    listen = *                      # Listen on these addresses ('*' for all)
    no-listen =                     # Do not listen on these addresses
    
    
                                    # CACHE OPTIONS
    
    zone-cache-size = 2048  # Maximum number of elements stored in the zone cache
    zone-cache-expire = 60  # Number of seconds after which cached zones expires
    reply-cache-size = 2048 # Maximum number of elements stored in the reply cache
    reply-cache-expire = 30 # Number of seconds after which cached replies expire
    
    
                                    # ESOTERICA
    
    log = LOG_DAEMON        # Facility to use for program output (LOG_*/stdout/stderr)
    pidfile = /var/run/mydns.pid    # Path to PID file
    timeout = 120   # Number of seconds after which queries time out
    multicpu = 1    # Number of CPUs installed on your system
    recursive =                     # Location of recursive resolver
    allow-axfr = yes # Should AXFR be enabled?
    allow-tcp = yes  # Should TCP be enabled?
    allow-update = no       # Should DNS UPDATE be enabled?
    ignore-minimum = no     # Ignore minimum TTL for zone?
    soa-table = dns_soa     # Name of table containing SOA records
    rr-table = dns_rr       # Name of table containing RR data
    soa-where = server_id = 1               # Extra WHERE clause for SOA queries
    rr-where =  server_id = 1               # Extra WHERE clause for RR queries
    use-soa-active = yes # To fix bug 295 where active or inactive status is ignored.
    use-rr-active = yes# To fix bug 295 where active or inactive status is ignored.
    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look into the syslog or messages log.
     
  3. pendexgabo

    pendexgabo New Member

    I've been having the same problem on Debian Lenny and ISPConfig 3.0.1.4

    reading in [1] they recommend to download and install the newest version [2]. I did it... let see how it goes


    Code:
    sssssss:/etc# mydns --version
    mydns (mydns) 1.2.8.27 (MySQL 5.0.51a)
    
    Copyright (C) 2002-2005 Don Moore  2007-2008 Howard Wilkinson
    Esto es software libre; vea el código fuente para las condiciones de copia.
    No hay NINGUNA garantía; ni siquiera de COMERCIABILIDAD o IDONEIDAD PARA UN
    FIN DETERMINADO.

    good luck to you and me :)

    [1] http://bit.ly/b1m4Up
    [2] http://mydns.pl/download
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Additionally you run a really old version of ISPConfig, so you should update to ISPConfig 3.0.2.2 too.
     

Share This Page