My postfix server is acting like a black hole.

Discussion in 'Server Operation' started by NeoTech, Aug 10, 2007.

  1. NeoTech

    NeoTech New Member

    I can se in the logs the mail gets delivered, the que removes it.. but it ends up.. Nowhere..

    Here goes logs.
    Anybody got any idea?? this is really annoying..
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use? What's the output of
    Code:
    netstat -tap
    ?
     
  3. NeoTech

    NeoTech New Member

    It's resolved.

    After 5 more hours of debugging i found that the "root" directive in main.cf where pointing at /var/mail/virtual/ so then the postfix appended the whole directory structure AGAIN, cause i have setted up the DB så courier-imap and postfix uses the same db fields.. i found a compromise that worked..

    But thanks for the answer anyway. =)
     
  4. southernman

    southernman New Member

    Glad it worked... but,

    Would you mind posting the steps you took to resolve the issue on the board. You'll then live in yet another legacy and countless generations to come will be grateful for your contributions... ;)

    Seriously though.. it would be nice if you wouldn't mind posting the steps you took to fix it.

    Thanks,

    ~ Steve
     
  5. NeoTech

    NeoTech New Member

    Resolving black hole issue with Postfix and Courier Pop & imap

    Problem number one, is the fact that courier and postfix utilises the same database settings for Reading and writing mail.

    The big difference between them is that one of them need a direct path to Maildir/ (Courier) and the other needs a relative path (Postfix)

    in the postfix settings it asks for the virtual maildir root. in my case it was /var/mail/virtual/ and in the maildir direction for courier i had set /var/mail/virtual/<domain>/<maildir>/

    Then i saw the mail ended up correctly in the server but couldnt find them. but notices after a while that a new directory structure ended up in /var/mail/virtual/ that was the whole virtual map structure all over again.

    By locating the virtual map root directiv in the postfix main.cf and setting it to / (root) instead of /var/mail/virtual/ the postfix would write all the mail correctly to the courier reading map, relativly to the root.

    Problem solved... Not really a blackhole issue just the damn fact that courier and postfix are intepreting the settings in the database differently.

    // Andreas
     

Share This Page