my postfix server doesn't work.

Discussion in 'Server Operation' started by robbiexu, Apr 19, 2010.

  1. robbiexu

    robbiexu New Member

    hello,every one.
    my mail server always work effectly,but it didn't work from the day before yesterday,i see the the log from /var/log/maillog as the following:
    Apr 19 12:24:28 abm-tech postfix/qmgr[4784]: B7136B09C7: from=<[email protected]>, size=3972, nrcpt=1 (queue active)
    Apr 19 12:24:28 abm-tech postfix/smtp[4795]: connect to[]: Connection refused (port 10024)

    how can i solve it?thank u.
  2. matty

    matty Member

    Try (re)starting amavisd.
  3. robbiexu

    robbiexu New Member

    the above first log was showed after i modify /etc/hosts.
    now,i reset my /etc/hosts,the following is new log.
    Apr 19 14:29:09 abm-tech postfix/qmgr[3203]: 55E7DB05AE: from=<[email protected]>, size=3908, nrcpt=1 (queue active)
    Apr 19 14:29:09 abm-tech postfix/smtpd[4533]: disconnect from[]
    Apr 19 14:29:09 abm-tech postfix/qmgr[3203]: 55E7DB05AE: to=<[email protected]>, relay=none, delay=0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to[]: Connection refused)
    ps:when i restart amavisd,there are a error.
    Missing process ID in file /var/spool/vscan/ at /usr/sbin/amavisd line 13463.
  4. robbiexu

    robbiexu New Member

    i deleted /var/spool/vscan/,but find new problem.i will post log if i can't solve it by myself for some time.
  5. robbiexu

    robbiexu New Member

    i found the problem maybe caused by clamd thread,my /var direction is always increased.
    i want to know 2 quesiton:
    1st:Does my server donwload virus library in order that the /var direction increased?
    2nd:Can i delete the old virus library file?and where are they?
    the following message appears when i run clamd
    LibClamAV Warning: ********************************************************
    LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
    LibClamAV Warning: *** DON'T PANIC! Read ***
    LibClamAV Warning: ********************************************************
    LibClamAV Error: Wrote 0 instead of 512 (/var/tmp/clamav-d2939173f3b521c6/COPYING).
    cli_untgz: No space left on device
    LibClamAV Error: cli_cvdload(): Can't unpack CVD file.
    LibClamAV Error: Can't load /var/clamav/main.cvd: CVD extraction failure
    ERROR: CVD extraction failure
  6. matty

    matty Member

    If you are using ubuntu or debian, try issuing 'apt-get autoclean'. That will remove any old outdated packages that are left over from past updates that might be cluttering up /var/cache/apt/archives. Another culprit could be log files. Have a look at what you have in /var/log. You might have had something output a lot of noise.

    Of cource, my ISPConfig 3/Perfect Setup on Debian Lenny installed mail into /var/vmail. You might just have too much email saved.

    You can check the size of directories with 'du -sh'. ie 'du -sh /var/*' will show you a summarised list of the sizes of everything in /var. It might help you track down the culprit.
  7. punk0mi

    punk0mi New Member

    As of April 15, 2010 Clam sent out a "disable" message to all ClamAV scan engines < 0.94. See

    I had this issue come up this week on my corporate server.

    You will need to completely remove the old version of clam and install the new one. The new virus definition files are not compatible with older scan engines. Until you get that fixed, amavis (I assume you are using it) will not function properly (unless you have a secondary or tertiary AV installed).

Share This Page