My Phpmyadmin keep showing me warning message

Discussion in 'Installation/Configuration' started by JULINT, Jan 16, 2021.

  1. JULINT

    JULINT Member

    Hi ,
    I have install ISPConfig with phpmyadmin.. but when logged in to phpmyadmin..
    i got this warning below.
    Please help me to solve this issue below

    Warning in ./libraries/sql.lib.php#613
    [​IMG] count(): Parameter must be an array or an object that implements Countable

    Backtrace

    ./libraries/sql.lib.php#2128: PMA_isRememberSortingOrder(array)
    ./libraries/sql.lib.php#2079: PMA_executeQueryAndGetQueryResponse(
    array,
    boolean true,
    string 'c1gcs_prod',
    string 'm_image',
    NULL,
    NULL,
    NULL,
    NULL,
    NULL,
    NULL,
    string '',
    string './themes/pmahomme/img/',
    NULL,
    NULL,
    NULL,
    string 'SELECT * FROM `m_image`',
    NULL,
    NULL,
    )
    ./sql.php#221: PMA_executeQueryAndSendQueryResponse(
    array,
    boolean true,
    string 'c1gcs_prod',
    string 'm_image',
    NULL,
    NULL,
    NULL,
    NULL,
    NULL,
    NULL,
    string '',
    string './themes/pmahomme/img/',
    NULL,
    NULL,
    NULL,
    string 'SELECT * FROM `m_image`',
    NULL,
    NULL,
    )
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    You need an updated phpmyadmin to work correctly with your php version.

    Perhaps you installed additional php versions and inadvertently changed your default php version? If so, just set it back to your OS's default.
     
  3. JULINT

    JULINT Member

    would you like to tell me , step by step to upgrade phpmyadmin ?
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    What operating system are you using? What version of phpnyadmin and how was it installed? What version of php is it running under?
     
  5. JULINT

    JULINT Member

    Hi ,

    OS : Ubuntu 18.04
    phpmyadmin version : 4.6.6deb5ubuntu0.5
    PHP : 7.2
    I have installed it by following ubuntu perfect server ubuntu 18.04 webserver apache
     
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

  7. JULINT

    JULINT Member

  8. JULINT

    JULINT Member

  9. JULINT

    JULINT Member

    Hi Jesse,

    I have found that error on /usr/share/phpmyadmin/autoload.php
    when it call :

    require_once 'PhpMyAdmin/MoTranslator/autoload.php';
    require_once 'PhpMyAdmin/ShapeFile/autoload.php';
    require_once 'PhpMyAdmin/SqlParser/autoload.php';
    require_once 'Symfony/Component/ExpressionLanguage/autoload.php';
    require_once 'Symfony/Component/DependencyInjection/autoload.php';
    require_once 'Symfony/Component/Config/autoload.php';
    require_once 'Symfony/Component/Yaml/autoload.php';
    require_once 'phpseclib/autoload.php';
    require_once 'Twig/autoload.php';
    require_once 'PhpMyAdmin/Twig/Extensions/autoload.php';
    require_once 'Williamdes/MariaDBMySQLKBS/autoload.php';
    require_once 'ReCaptcha/autoload.php';
    Then got http 500...
     
  10. JULINT

    JULINT Member

    This file is not found require_once 'PhpMyAdmin/MoTranslator/autoload.php';

    so it trigger http 500
     
  11. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    I think that it would better to uninstall PMA package that comes with the OS and install its latest package manually following the guide in the latest Debian PST.
     
  12. JULINT

    JULINT Member

    Thanks for your clue, it is working now
     
    ahrasis likes this.

Share This Page