My Perfect (ISPConfig) Server

Discussion in 'Installation/Configuration' started by theashman, Oct 16, 2008.

  1. theashman

    theashman New Member

    Thanks for looking.

    I recently setup my own perfect server using ubuntu 7.10 by following the instructions in the perfect server tutorial on here. I first of all broke my internet connection and was unable to connect to the updater for ubuntu. I managed to fix that by changing some of the values mentioned in step 7 on this page:

    i changed it to this:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    # The loopback network interface
    auto lo
    iface lo inet loopback
    # The primary network interface
    auto eth0
    iface eth0 inet dhcp
    and boom i had my internet connection back.

    I setup my ubuntu using as mentioned in the tutorial but when it came to installing ISPC i couldn't use that address as domain it asks for when asking about mysql stuff etc... so i just entered and i can access ISPC using that IP. I'm using virtual box and running ubuntu as a VM on windows xp. I tried entering that ip address to access ISPC from windows but it didnt work.

    I now have a domain I would like to use and I have also discovered that my IP address is static. What inside ubuntu/ISPC do i need to change to make my server accessible externally?

    Thanks for your help.
  2. AcidKat

    AcidKat New Member

    make the address static and forward the relevant ports in your router
  3. Rocky

    Rocky New Member

    Yes, make the IP static and also make sure you have a FQDN registered for your setup.
  4. theashman

    theashman New Member

    FQDN? i purchased this domain:

    which sections if ISPC do i edit?

    sorry, im a total noob at this

    Last edited: Oct 16, 2008
  5. falko

    falko Super Moderator ISPConfig Developer

    If you use, you cannot access ISPConfig from the outside. You could've used instead. For the hostname, you could create an A record at your domain registrar (e.g. that points to your router's public IP address.

    You can change these settings in /home/admispconfig/ispconfig/lib/ and /root/ispconfig/httpd/conf/httpd.conf. Restart ISPConfig afterwards.

Share This Page