My ISPConfig3 does not connect to phpmyadmin - what to check next

Discussion in 'Installation/Configuration' started by eko_taas, Mar 6, 2011.

  1. eko_taas

    eko_taas New Member

    Searched earlier posts, but bit diff. issues...

    I'll have fresh Squeeze + ISPConfig3 (installed as per manual and howto), till now just tested basics of ISPConfig3 (no tuning ;))

    (My servername is named as it's fixed local IP-address as too many problems with Zyxel ADSL-modem's port-forwarding, google full of links to this bug)

    While making 1st tuning and following howto change webmail to RoundCube
    ...Till step 4.

    Problem: Server's phpmyadmin does to open (at least I can't).

    I have tried from server itself and other machine on same network:
    - by ISPConfig links (e.g. (link acts, but result...)
    - manually
    resulting e.g
    - manually http.// (with and w/o .php-end)
    - manually http.// (with and w/o .php-end)
    resulting e.g.
    Also checked (these were asked in earlier postings on similar subhject, so just in case given here also):
    - http-server (80) and administration-site (8080) works w/o issue (both and
    - Roundcube DB 'Remote access' and 'active' selected (just in case makes difference). Also database name and psw only letters
    - network status (just in case helps)
    What could I check next :confused:
  2. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use? How did you install phpMyAdmin?
  3. eko_taas

    eko_taas New Member

    As said earlier I'll have fresh (Debian) Squeeze (with net installer) + ISPConfig Version:

    Only extra I'll have is gnome-basics (before any ISPConfig3 installations)
    Commands made in root-terminal (on server itself)

    Installation done as per your perfect instructions (including phpMyAdmin)
    Where items 12 seems to cover your question
  4. eko_taas

    eko_taas New Member

    Some extra checks:
    - Synaptic Packager Manager: 4:3.3.7-5 installed (same as latest version)
    - /etc/phpmyadmin files exists, but don't know what to check...
  5. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    ls -la /etc/apache2/conf.d/
  6. eko_taas

    eko_taas New Member

    Thanks for your effort :)
    $ ls -la /etc/apache2/conf.d/
    total 28
    drwxr-xr-x 2 root root 4096 Mar  4 18:38 .
    drwxr-xr-x 7 root root 4096 Mar  4 17:54 ..
    -rw-r--r-- 1 root root  237 Jan  1 21:58 apache2-doc
    -rw-r--r-- 1 root root  269 Jan  1 22:23 charset
    lrwxrwxrwx 1 root root   45 Mar  4 17:54 javascript-common.conf -> /etc/javascript-common/javascript-common.conf
    -rw-r--r-- 1 root root 3296 Jan  1 22:23 localized-error-pages
    -rw-r--r-- 1 root root  143 Jan  1 22:23 other-vhosts-access-log
    -rw-r--r-- 1 root root 1424 Jan  1 22:23 security
    lrwxrwxrwx 1 root root   30 Mar  4 18:38 squirrelmail.conf -> ../../squirrelmail/apache.conf
    Also googled based on given folder name and "phpmyadmin not starting" and ended up to
    so I added as root
    restarted server (to see all fresh)

    Now working, thanks for you help!

    Last edited: Mar 9, 2011

Share This Page