My ISP BLOCKS PORT 80. What can I do?

Discussion in 'Installation/Configuration' started by sierradump, Jun 13, 2007.

  1. sierradump

    sierradump New Member

    So I spent the hours and time and got ISPConfig setup and working great at home using private IP's. I set up the rules this new sonicwall to forward port 80 and 81 to my ISPConfig server. I slept well thinking that tomarrow I could remotley setup all my sites. Well I get to work and DAMNIT - I can get to web admin interface (port 81) but freaking port 80 was "connection timed out". After another hour or two double checking things I call my ISP.

    THEY BLOCKED PORT 80 INBOUND. And not only that - they cut off my other IP addresses ALL WITHOUT TELLING ME. "we went through some changes yadda yadda and no longer support multiple or static IP's"...

    Anyway... I know I just need to change the apache config file to listen on another port, say 8080, BUT HOW/WHERE DO I DO THIS? And do I only need to change the port in the apache httpd.conf file? OR is there other associations like the firewall and whatnot that need to also be configured???

    And there are 2 instances of apache installed correct? One with the linux OS and I remember that ISPConfig does its OWN apache install -- Where are these httpd.conf files located (im running centos if it matters)

    Last edited: Jun 13, 2007
  2. falko

    falko Super Moderator ISPConfig Developer

    For CentOS, I think the APache configuration is in /etc/httpd/conf/httpd.conf (or similar).
    ISPConfig's Apache configuration is in /root/ispconfig/httpd/conf/httpd.conf.

    To change the port, you must change Listen 80 in/etc/httpd/conf/httpd.conf. Also, you must change port 80 in the function make_vhost() in /root/ispconfig/scripts/lib/config.lib.php.
  3. sierradump

    sierradump New Member

    Thanks Falko!

    Falko - your the best! I really enjoy reading your how-to's.
    Last edited: Jun 13, 2007
  4. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    im having the same problem and i tried changing the port in /etc/httpd/conf/httpd.conf and in make_vhost and it still goes to the fedora test page and not the ispconfig place holder
  5. sierradump

    sierradump New Member

    After you change the ports in the config files, you'll need to restart your server.

    ALSO NOTE: These changes won't change the ISPConfig sites you already built... You should install ISPConfig and immediatley change the ports in the config file... Then start setting up the sites... Best to do this from scratch...

    By the way --- how are you going to setup your domains to point to the new Port??? I posted a separate thread asking that question and nobody has responded yet?
  6. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    im just port forwarding, but i did try to restart it and it still says the web server is offline
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig chceks a webserver on port 80, if you changed the port, ISPConfig will show the webserver as offline.
  8. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    is there any way to get it to check on a different port
  9. sierradump

    sierradump New Member


    I think you might be confused???? I have a ISPConfig box that is serving sites on port 8080. My control panel is still on default 81 (which wasn't blocked for me).

    I followed the "cent os 4.5 HOW-TO" to the letter. In fact, just to be on the safe side, setup a SSH to the box your setting up and just copy/paste his commands straight to your box (changing the passwords and host names of course)... Then when you are all done; follow his directions in the 2nd post in this thread.

    I ONLY CHANGED 2 FILES. All I did to those 2 files was change the port from 80 to 8080 as per the directions in post 2.

    ALSO - I think you mentioned Fedora in one of your posts; per chance maybe the locations to the config files are different for your distro? Again, I used CENT OS 4.5 and if you follow the directions in this post I guaruntee it will be serving/listening on port 8080 (or whatever port you change to...)
  10. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    thanks for the info I got it now and its working
  11. sierradump

    sierradump New Member

    What did you end up doing to "get it working". Maybe you have a better solution?

    Did you add both port 80 and (your new port) or just (your new port)... I forgot to mention that as well...

    Otherwise - as till says - you'll get a "offline" message (but as you noticed, it still works - shows you your webpage)
  12. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    i went with what you said and put ports 80 and 8081 and it comes up as online and works, as far as the whole problem with getting the shared ip message thats the next thing to tackle :)
  13. falko

    falko Super Moderator ISPConfig Developer

    You must use the correct URL to access the web sites. For example, if you created a web site, you must use in your browser and nothing else (like just, for example).
    Also, you must make sure that you use the correct IP address for the web sites in ISPConfig. It must be one of the IP addresses you see in the output of

Share This Page