My Cron Log are full of the same " PHP Deprecated"

Discussion in 'ISPConfig 3 Priority Support' started by babydunk, Jun 21, 2016.

  1. babydunk

    babydunk Member HowtoForge Supporter

    Hello
    can anyone point how to fix this ?

    i could find only one other thread and it said about an incompatiblity with php7. i dont have php7 installed.

    many thnaks
    Chris
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which ISPConfig version do you use, which PHP version and which operating system version?
     
  3. babydunk

    babydunk Member HowtoForge Supporter

    Good Morning Till

    i am on version ISPConfig Version: 3.0.5.4p9 and Debian 8.4
     
  4. babydunk

    babydunk Member HowtoForge Supporter

    my PHP version was upgraded a couple of days ago to
    PHP Version 5.6.22-0+deb8u1
     
    Last edited: Jun 21, 2016
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You should change the error reporting level in the /ec/php5/cli.php.ini to not show deprecated messages. These messages do not indicate a problem, they are just made for developers to show them which functions will get removed in future PHP versions so that they can adjust their code as we already did in ISPConfig 3.1. For you as a end user, this messages just fill the log and are not of any real use, so its better to hide them and show just errors, warnings and maybe notices in PHP.
     
    babydunk likes this.

Share This Page