MX records check and SMTP greeting

Discussion in 'ISPConfig 3 Priority Support' started by wowakan, May 31, 2014.

  1. wowakan

    wowakan New Member

    I know I put two problems here but thought better to, "kill two birds with one stone".

    Errors are from

    Not sure how to do this one first warning or if it really needs to be fixed.
    MX records check:
    Only one MX record exists within the zone. This is ok, but it is a better practice to have at least two mail servers operating on a domain, to ensure more reliable mail deliverability. The MX record provided is:

    preference = 10 []

    Now this I have looked through other posting and I just can't get a handle on it, maybe I am looking to hard at it or over processing it. But with this one please baby steps.
    SMTP greeting
    Malformed greeting or no A records found matching banner text for following servers, and banner is not an address literal. RFC5321 requires one or the other (should not be a CNAME). If this is not set correctly, some mail platforms will reject or delay mail from you, and can cause hard to diagnose issues with deliverability. Mailserver details: | WARNING: The hostname in the SMTP greeting does not match the reverse DNS (PTR) record for your mail server. This probably won't cause any harm, but may be a technical violation of RFC5321
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats ok and not an error. It is absolutely fine to have just one MX record and it does not make sense to have more then one MX record when you have just one server.

    Please check your postfix file and /etc/mailname and ensure that the hostname "" is set there in mydomain, mydestination and myhostname and not the IP address. if you find the IP in one of these 3 settings, then replace it with the hostname and leave the other parts of the setting like "localhost" intact.

    Then restart postfix.

    Next ask your ISP (the one that assigned you the IP address) to set a reverse dns record for the IP address to "".
  3. wowakan

    wowakan New Member

    as far as MX records check, this is in fact what I thought.

    This is what I changed in the postfix.conf from what I am understanding from you.

    I also have, and Would I in fact add those also? As far as my ISP goes, comcast will only add they will not add

    I am not finding /etc/mailname. where in centos 6.5 is this please?

    # The myhostname parameter specifies the internet hostname of this
    # mail system. The default is to use the fully-qualified domain name
    # from gethostname(). $myhostname is used as a default value for many
    # other configuration parameters.
    myhostname =
    #myhostname = virtual.domain.tld

    # The mydomain parameter specifies the local internet domain name.
    # The default is to use $myhostname minus the first component.
    # $mydomain is used as a default value for many other configuration
    # parameters.
    mydomain =

    # Specify a list of host or domain names, /file/name or type:table
    # patterns, separated by commas and/or whitespace. A /file/name
    # pattern is replaced by its contents; a type:table is matched when
    # a name matches a lookup key (the right-hand side is ignored).
    # Continue long lines by starting the next line with whitespace.
    # See also below, section "REJECTING MAIL FOR UNKNOWN LOCAL USERS".
    mydestination =,, localhost, localhost.localdomain
    #mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
    #mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain,
    # mail.$mydomain, www.$mydomain, ftp.$mydomain
    Last edited: Jun 3, 2014
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please change mydomain to:

    mydomain =

    and restart postfix. You may not list a domain name that shall be used for sending or receiving emails in mydomain, mydestination or myhostname in a postfix virtual user setup.

    Thats ok, you can leave this part out then. This is a file that exists on Debian and Ubuntu only.
  5. wowakan

    wowakan New Member

    ok still didn't work. I am going to call Comcast again and talk to another tech. I think they should be able to do it. Want to say how I feel personal but will not about comcast.
  6. wowakan

    wowakan New Member

    ok went to and it says everything is fine. go figure.
  7. wowakan

    wowakan New Member

    ok called up comcast and they changed it to

    Would I need to change this at all?
    # The smtpd_banner parameter specifies the text that follows the 220
    # code in the SMTP server's greeting banner. Some people like to see
    # the mail version advertised. By default, Postfix shows no version.
    # You MUST specify $myhostname at the start of the text. That is an
    # RFC requirement. Postfix itself does not care.
    #smtpd_banner = $myhostname ESMTP $mail_name
    #smtpd_banner = $myhostname ESMTP $mail_name ($mail_version)
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The smtpd_banner is ok, so you dont have to change that.
  9. wowakan

    wowakan New Member

    Ok so as far as I am seeing this issue is resolved. I will have one more issue and that is it.

Share This Page