MX records are not exposed

Discussion in 'Installation/Configuration' started by SyRenity, Dec 4, 2006.

  1. SyRenity

    SyRenity New Member

    Hi.

    For some reason, any DNS zone managed by ISPConfing does not expose it's MX records.

    For example: http://www.dnsstuff.com/tools/traversal.ch?domain=hatarsi.com&type=MX (both of the DNS IP's are from the same single ISPConfig server).

    While I have defined for hatarsi.com the MX record mail.hatarsi.com.

    Any idea what might prevent from ISPConfig to show the MX records?
     
    Last edited: Dec 4, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    Is 64.187.96.17 your server's IP address? What's in the hatarsi.com zone file?
     
  3. SyRenity

    SyRenity New Member

    Yes, this is the IP address of the server. Below are the contents of the hatarsi.com zone file:

    $TTL 86400
    @ IN SOA www.n1-business.com. admin.hatarsi.com. (
    2006120401 ; serial, todays date + todays serial #
    28800 ; refresh, seconds
    7200 ; retry, seconds
    604800 ; expire, seconds
    86400 ) ; minimum, seconds
    ;

    NS www.n1-business.com. ; Inet Address of name server 1
    NS www.n1-business.com. ; Inet Address of name server 2
    ;

    mail MX 10 mail.hatarsi.com.

    hatarsi.com. A 64.187.96.17
    www A 64.187.96.17
    mail A 216.127.82.26
    @ A 64.187.96.17

    ;;;; MAKE MANUAL ENTRIES BELOW THIS LINE! ;;;;
     
    Last edited: Dec 12, 2006
  4. SyRenity

    SyRenity New Member

    It seems to happen with all the domains managed by ISPConfig DNS. Perhaps it due to the instaleld local mail server? Or there some record might be missing?

    Thanks in advance.
     
  5. falko

    falko Super Moderator ISPConfig Developer

  6. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Well, I'm not sure if the nameserver entries themselves are oke. Why do you use www..... for both nameservers? I would add two dns entries with e.g. ns0 and ns1 to seperate these from your website.
     
  7. SyRenity

    SyRenity New Member

    Thanks Falko, this resolved the problem :).

    I'll check why the NS are begning with www, because the real NS are indeed begin with ns1 and ns2. This what btw the dnsstuff traversal shows as well:

    http://www.dnsstuff.com/tools/traversal.ch?domain=hatarsi.com&type=MX

    ns1.n1-business.com [64.187.96.17] 10-mail.hatarsi.com.
    ns2.n1-business.com [64.187.96.57] 10-mail.hatarsi.com.
     

Share This Page