mx domains visible in google search causing duplicate content

Discussion in 'Installation/Configuration' started by dynamind, Mar 30, 2012.

  1. dynamind

    dynamind Member

    hello,

    there something really weird happening now, I check google for all index sites and found:

    http://www.google.at/#hl=de&q=site:seo-werbeagentur.com

    do you have an idea whats wrong suddenly?? the mx01 andd mx02 domains are indexed in google :S
    this issues only appears on domains bought at domain.com ... not with domains registered at easyname or dot.tk
    could it be an ISPconfig related issue or can it depend on the nameservers from domain.com?
     
    Last edited: Mar 30, 2012
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The issue itself is not caused by ispconfig, but there are some genarl considerations that you should do for all hosted websites when it comes to duplicate content:

    1) Create only the nescessary dns records. E.g. ceate a a-record for the domain and a a-record for the www subdomain and dont use wildcard (*) DNS records.

    2) Dont use wildcard subdomains in apache. Check your website settings and ensure that you use e.g. auto subdomain www and not auto subdomain *.
     
  3. dynamind

    dynamind Member

    dns settings

    [​IMG]

    that's so curious, I have changed nothing and now this results!
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The mx01 and mx02 records dont come from this dns server. Either this dns server is not the authoritive dns server for the domain or the records are added in the dns server of the domain registrar directly.
     
  5. dynamind

    dynamind Member

    [​IMG]

    do you see an error in the settings?
    there is even something else I can't explain, I set the redirect to www. now and curl shows this result:

    C:\windows\system32>curl -I www*mx01.semseo-agency*com
    HTTP/1.1 301 Moved Permanently
    Date: Fri, 30 Mar 2012 07:02:41 GMT
    Server: Apache
    location: hxxp://www.seo-werbeagentur.com/
    Vary: Accept-Encoding
    Content-Type: text/html

    different domain, how come!
     
    Last edited: Mar 30, 2012
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You have a wildcard dns as I described above and this can cause your problem and should never be set if you care abot seo.

    Regarding your curl test: the redirect is ok and recommended for seo.
     
  7. dynamind

    dynamind Member

    yes till, but the redirect leads to a dfifferent domain:

    C:\windows\system32>curl -I www*mx01.semseo-agency*com
    HTTP/1.1 301 Moved Permanently
    Date: Fri, 30 Mar 2012 07:02:13 GMT
    Server: Apache
    location: hxxp://www.seo-werbeagentur.com/
    Vary: Accept-Encoding
    Content-Type: text/html

    I removed the wildcards and I don't know how this result gets resolved. The curiosity aside is:

    http://www.google.at/#hl=de&q=site:rank-king.eu

    [​IMG]

    No problem with domains registered at easyname even with wildcards.
    The dns from domain.com is devil-driving my server : ( when I use wildcards.
     
    Last edited: Mar 30, 2012
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    There are severalpossibilitys:

    Check your .htaccess files and if you use cms systems, check tehs efor redirects too.
     
  9. dynamind

    dynamind Member

    .htaccess already checked

    RewriteCond %{HTTP_HOST} !^www\. [NC]
    RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

    this should be good, there's no cms, it pure html.
     
  10. dynamind

    dynamind Member

    email server unreachable

    I get this response now:

    Hi. This is the qmail-send program at mailout-de.gmx.net.
    I'm afraid I wasn't able to deliver your message to the following addresses.
    This is a permanent error; I've given up. Sorry it didn't work out.

    <[email protected]>:
    Sorry,_I_couldn't_find_a_mail_exchanger_or_IP_address._(#5.4.4)/

    clusterfu#ยง!% ... I'll pull my domain and switch to easyname.
     
    Last edited: Mar 30, 2012

Share This Page