MX and DNS records

Discussion in 'Server Operation' started by xtine, Jun 11, 2008.

  1. xtine

    xtine New Member

    My platform
    OpenSuse 10.2
    Postfix 2.3.2_28
    ISPConfig 2.2.23

    DNS configs
    Using "example" in lieu of my domain name, and in lieu of my IP)
    * I run my own DNS server as primary, and use 1and1's as secondary
    * In ISPConfig, under ISP Manager: Co-Domains set up for and, with DNS MX unchecked
    * In ISPConfig, under DNS Manager:
    - A Names set up for,,,
    - MX set up for for priority 10, priority 20
    - SPF set up for for
    * I also checked that the above records are in my /var/lib/named/ file

    mail MX 10
    MX 20 A
    www A
    ns1 A
    mail A A --- somehow I have two of these, do I need to delete the A Name from ISPConfig? Does the creation of a Co-Domain in ISPConfig automatically create an A Name? Does this extra line matter? TXT "v=spf1 a mx ptr ~all"

    What's working
    * DNS is working, I'm able to browse (via browser) to the domain name and co-domains set up in ISPConfig. I'm also able to ping the domain and various sub-domains.
    * I'm able to hook up Outlook client to my mail server, have successfully send and received emails to/from Gmail/Yahoo Mail.

    What's not quite working
    1) When testing my server on and, the tools reports back that "No MX records for '', using its A record(s)". I don't understand why this is since ISPConfig shows that I have MX records set up, and file displays the MX records. What am I missing?

    2) Mail sent to Yahoo Mail goes straight to Spam Folder. I read that one common issue is if the mail server has open relay. I checked my server using the diagnostic tool on mxtoolbox, and it says that the server is not open relay so that's not it. Someone else suggested using a signature, I did, but there's no impact either. Mail still gets sent to the spam folder. (But this doesn't happen on Gmail, the mail goes to my Inbox on Gmail just fine.) I wonder if problem #1 causes the problem #2? :confused:
    Last edited: Jun 17, 2008
  2. falko

    falko Super Moderator ISPConfig Developer

    Please check if your name server is responsible for the domain. you can do that by running
    dig ns
    Please check if your server is blacklisted:
  3. xtine

    xtine New Member

    Yes it is. This information was seen on the test as well.

    Checked, and it's not blacklisted from the servers that responded. 5 servers timed out.

    Other ideas?
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    dig mx

    Do you have an SPF record for
  5. xtine

    xtine New Member

    Output for dig mx -

    I have set up as a SPF record in ISPConfig. Here's the corresponding line on the file.
  6. xtine

    xtine New Member

    Another funny thing is that mail sent via an Outlook client takes a while to receive at Yahoo Mail. But from the same server, mail from root gets to Yahoo Mail immediately. Why's that?
  7. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log?

    Can you run dig against your DNS server directly?
    dig @your.dns.server mx
    What's the output?
  8. xtine

    xtine New Member

    In /var/log/mail.err, I have a ton of these every time my Outlook is opened.

    I get the following from tail /var/log/mail.warn. I guess this is benign.

    b169:/var/log # dig mx

    Same answer was received from secondary DNS
    b169:/var/log # dig mx

    Last edited: Jun 17, 2008
  9. falko

    falko Super Moderator ISPConfig Developer

    Please restart famd.

    postmap /etc/postfix/virtusertable
    and restart Postfix.

    Replace check_relay_domains with reject_unauth_destination in /etc/postfix/ and restart Postfix.

    What's in /etc/named.conf?
  10. chipsafts

    chipsafts New Member

    first off, is it '' or '' ?

    there is no MX reported by the dig,
    when is the last time you restarted the named ?
    When you do restart it, check the /var/log/messages for all the information logged by named.
  11. xtine

    xtine New Member

    Falko -

    I restarted famd, ran postmap /etc/postfix/virtusertable, and restarted postfix. It seems I have the same problem that's described in this thread in regards to the virtusertable. Should I run the postmap command and restart postfix every so often? How often?

    In /etc/named.conf. Note: substitution names are used, in navy ( and

    Chipsafts -

    I had a typo. It's just a substitution. ;)

    A couple of weeks ago when I set it up. I just restarted it and this is what's seen in /var/log/messages (substitutions in navy).

  12. falko

    falko Super Moderator ISPConfig Developer

    I don't know why this happens (SUSE - sigh...), but you must do this whenever you see the warning.

    Can you post your /etc/named.conf?
  13. xtine

    xtine New Member

    This is what's in my /etc/named.conf (I just chopped off the comments). Note: substitution names are used, in navy ( and

  14. xtine

    xtine New Member

    A friend came over to my house and looked at this for me. Turns out the culprit is this line in the file.

    He explained to me that since this is the first line for MX, DNS is using the MX records for the subdomain. Once I removed that line, is able to see my MX record. Yay!

    I'm still getting a delay in sending mail to Yahoo though. I've emailed their support team, but haven't received anything useful yet. This is what's seen on my log.
    The behavior is changing, it seems. Yesterday, there was no delay in delivering the mail, but it ended up in the Spam Folder still. Today, there's a delay in delivering the mail (around 30 minutes), but the mail arrived in my Inbox instead of the Spam Folder.

    I wonder if the postfix virtusertable issue has something to do with ISPConfig.
    Last edited: Jun 17, 2008
  15. falko

    falko Super Moderator ISPConfig Developer

    This is your Postfix configuration. Is it possible that you saved it in your named.conf instead of in /etc/postfix/
  16. xtine

    xtine New Member

    Hey Falko,

    My bad. Below is the /etc/name.conf. I'm good with the MX record though now. :D

    The only remaining problem I have is delay in getting email to Yahoo Mail at this point.

    From, I got a "heads-up," do I need to do anything about this?
  17. falko

    falko Super Moderator ISPConfig Developer

    The named.conf looks good. What's in

    You should ask your hosting company to set up a PTR record for you.
  18. xtine

    xtine New Member

    In my
    This is what I do dig -x (my IP), I get
    Is this sufficient as far as PTR is concerned or do I need more?
  19. falko

    falko Super Moderator ISPConfig Developer

    Looks ok.

    Yes, that's sufficient.

Share This Page