Munin working under FQDN of server with https

Discussion in 'Installation/Configuration' started by chab43, Oct 20, 2016.

  1. chab43

    chab43 New Member HowtoForge Supporter

    Hey all, I was wondering if anyone has suggestions on how I can get Munin working via https running under my servers FQDN, ie: https://ispconfig.myserver.com/munin
    Currently I can access munin via any of my websites hosted on the server at: http://example.com/munin
    Here is my debug log: http://pastebin.com/RvQyS7Qq
    This is the tutorial I followed: https://www.howtoforge.com/tutorial/server-monitoring-with-munin-and-monit-on-debian/

    I setup ISPConfig to use a lets encrypt certificate following Jesse's advice here and I managed to get monit working using the LetsEncrypt certificate. I had to manually put the certificate, chain, and private key file into a single file as monit doesn't appear to have an option to specify them individually. Anyone know of a way I could do this automatically when LetsEncrypt renews the certificate?

    Now for my munin issue, I tried to just append the information from the apache24.conf file to the end of the ispconfig.vhost file but that didn't work. I tried to access it by just going to https://ispconfig.myserver.com/munin but Chrome doesn't like it because of HSTS. I saw a couple tutorials online that suggest making an apache vhost file instead of the config file like your tutorials suggest, I am assuming the vhost file would be more suited to what I am trying to accomplish?
     
    Last edited: Oct 20, 2016
  2. chab43

    chab43 New Member HowtoForge Supporter

    also what URL do I need to put in ISPConfig for Munin to work under the monitor section? I tried the base example.com/munin/ and example.com/munin/example.com/server.example.com/index.html (where you see the actual graphs) and neither of them want to show up in ISPConfig.
     

Share This Page