Munin not generating anything

Discussion in 'HOWTO-Related Questions' started by Sigmahawk, Apr 14, 2009.

  1. Sigmahawk

    Sigmahawk New Member

    I believe I've got munin set up correctly, but there isn't any chart in the /munin/ folder, it just shows style.css and cgi.

    I've set up both conf files, and set up permissions. I'm running it on CentOS4.7.

    What would be the most likely cause of this problem? there is only one log file, and it contains this:

    2009/04/14-02:00:18 MyPackage (type Net::Server::Fork) starting! pid(32699)
    Binding to TCP port 4949 on host localhost
    Setting gid to "0 0"
     
  2. falko

    falko Super Moderator

    Can you go to the munin/ folder and post the output of
    Code:
    ls -la
    ?
     
  3. flameproof

    flameproof New Member

    Since this seems idle maybe I can ask for help with the same problem..

    I followed this instruction for #1 and #2:

    http://www.howtoforge.org/server_monitoring_monit_munin

    munin.conf is:

    user and groups is set to munin. But I get no data in the directory.

    /var/log/munin has also no action, just munin-node.log has a few lines:

    What could be the error?
     
  4. falko

    falko Super Moderator

    What's the output of
    Code:
    ls -la /home/mydomain/public_html/munin/
    ?
     
  5. Franz

    Franz Member

    try:

    Code:
    telnet localhost 4949
    and then

    Code:
    list
    
     
  6. flameproof

    flameproof New Member

    Thanks for the help... here is what I got:

    Code:
    [B]#ls -la /home/mydomain/public_html/munin/[/B]
    total 8
    drwxr-xr-x  2 munin   munin   4096 Aug 18 22:56 .
    drwxr-xr-x 19 mydomain mydomain 4096 Aug 18 22:56 ..
    
    
    [B]# telnet localhost 4949[/B]
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    # munin node at vps-888888-888.vpshost.com
    Connection closed by foreign host.
    
    [B]# list[/B]
    -bash: list: command not found
    Any clues from it?
     
  7. falko

    falko Super Moderator

    What's the output of
    Code:
    ls -la /home/mydomain/
    ?

    Is SELinux disabled?
     
  8. flameproof

    flameproof New Member

    Code:
    [B]# ls -la /home/mydomain[/B]
    total 68
    drwxr-xr-x 12 mydomain mydomain 4096 Jul 29 01:34 .
    drwxr-xr-x  9 root    root    4096 Jul  2 22:03 ..
    -rw-r--r--  1 mydomain mydomain   22 Jan  8  2009 .awstats-htpasswd
    -rw-r--r--  1 mydomain mydomain   33 Jan  8  2009 .bash_logout
    -rw-r--r--  1 mydomain mydomain  176 Jan  8  2009 .bash_profile
    -rw-r--r--  1 mydomain mydomain  124 Jan  8  2009 .bashrc
    drwx------  2 mydomain mydomain 4096 Jan 17  2009 .spamassassin
    -rw-r--r--  1 mydomain mydomain   22 May 31 09:12 .stats-htpasswd
    drwx------  3 mydomain mydomain 4096 Jan  8  2009 .usermin
    drwx------  6 mydomain mydomain 4096 Jun  3 07:41 Maildir
    drwxr-xr-x  2 mydomain mydomain 4096 May 31 09:01 awstats
    drwxr-x---  2 mydomain mydomain 4096 May 31 09:12 cgi-bin
    drwxr-xr-x  3 root    root    4096 Jan  8  2009 database
    drwxr-xr-x  2 mydomain mydomain 4096 Jan  8  2009 etc
    drwxr-xr-x  7 mydomain mydomain 4096 Feb  2  2009 homes
    drwxr-x---  2 mydomain mydomain 4096 Aug 16 04:02 logs
    drwxr-xr-x 19 mydomain mydomain 4096 Aug 18 22:56 public_html
    Is SELinux disabled?


    I have no idea....
     
  9. falko

    falko Super Moderator

    What's the output of
    Code:
    getenforce
    ?
     
  10. flameproof

    flameproof New Member

    Code:
    # getenforce
    Disabled
    
     
  11. falko

    falko Super Moderator

    Ok, SELinux is disabled, so that's not the problem. I have no idea why it's not working for you... :(
     
  12. phython

    phython New Member

    if some one has this problem - check if crond is started!
    that solved my problem
    centos 6 minimal install crond is not stratring on boot
     

Share This Page