Munin-node Installation problem

Discussion in 'Installation/Configuration' started by discovery, May 30, 2007.

  1. discovery

    discovery New Member

    Hi, I am Installing munin using these steps:

    1. On this Dir : /usr/src i have downloaded
    wget ftp://rpmfind.net/linux/dag/redhat/el5/en/x86_64/dag/RPMS/munin-node-1.2.5-1.el5.rf.noarch.rpm

    2. ON cd /etc/yum.repos.d and have a file rpmforge.repo with the following entries:
    [rpmforge]
    name = Red Hat Enterprise $releasever - RPMforge.net - dag
    baseurl = http://apt.sw.be/redhat/el5/en/$basearch/dag
    enabled = 1
    3. yum install /usr/src/munin-node-1.2.5-1.el5.rf.noarch.rpm

    But its gives error

    Loading "installonlyn" plugin
    Setting up Install Process
    Setting up repositories
    rpmforge 100% |=========================| 1.1 kB 00:00
    base 100% |=========================| 1.1 kB 00:00
    updates 100% |=========================| 951 B 00:00
    addons 100% |=========================| 951 B 00:00
    extras 100% |=========================| 1.1 kB 00:00
    Reading repository metadata in from local files
    Parsing package install arguments
    Examining /usr/src/munin-node-1.2.5-1.el5.rf.noarch.rpm: munin-node - 1.2.5-1.el5.rf.noarch
    Marking /usr/src/munin-node-1.2.5-1.el5.rf.noarch.rpm to be installed
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Package munin-node.noarch 0:1.2.5-1.el5.rf set to be updated
    --> Running transaction check
    --> Processing Dependency: perl-Net-Server for package: munin-node
    --> Processing Dependency: perl(Net::SNMP) for package: munin-node
    --> Processing Dependency: perl(Net::Server::Fork) for package: munin-node
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Package perl-Net-SNMP.noarch 0:5.2.0-1.2.el5.rf set to be updated
    ---> Package perl-Net-Server.noarch 0:0.96-1.el5.rf set to be updated
    --> Running transaction check
    --> Processing Dependency: perl(Crypt::DES) for package: perl-Net-SNMP
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Package perl-Crypt-DES.x86_64 0:2.05-3.2.el5.rf set to be updated
    --> Running transaction check

    Dependencies Resolved

    =============================================================================
    Package Arch Version Repository Size
    =============================================================================
    Installing:
    munin-node noarch 1.2.5-1.el5.rf /usr/src/munin-node-1.2.5-1.el5.rf.noarch.rpm 479 k
    Installing for dependencies:
    perl-Crypt-DES x86_64 2.05-3.2.el5.rf rpmforge 37 k
    perl-Net-SNMP noarch 5.2.0-1.2.el5.rf rpmforge 96 k
    perl-Net-Server noarch 0.96-1.el5.rf rpmforge 154 k

    Transaction Summary
    =============================================================================
    Install 4 Package(s)
    Update 0 Package(s)
    Remove 0 Package(s)

    Total download size: 767 k
    Is this ok [y/N]: Y
    Downloading Packages:
    warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 6b8d79e6


    Public key for perl-Net-SNMP-5.2.0-1.2.el5.rf.noarch.rpm is not installed
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Try
    Code:
    rpm -ivh /usr/src/munin-node-1.2.5-1.el5.rf.noarch.rpm
    instead.
     
  3. discovery

    discovery New Member

    Thanks ,


    Its working for me.
     
  4. tfunky

    tfunky New Member

    I'm having a similar issue...

    Code:
    [[email protected] src]# rpm -ivh /usr/src/munin-node-1.2.5-1.el5.rf.noarch.rpm
    warning: /usr/src/munin-node-1.2.5-1.el5.rf.noarch.rpm: Header V3 DSA signature: NOKEY, key ID 6b8d79e6
    error: Failed dependencies:
            perl(Net::SNMP) is needed by munin-node-1.2.5-1.el5.rf.noarch
            sysstat is needed by munin-node-1.2.5-1.el5.rf.noarch
    [[email protected] src]#
    [[email protected] src]# rpm -ivh /usr/src/munin-node-1.2.5-1.el5.rf.noarch.rpm
    warning: /usr/src/munin-node-1.2.5-1.el5.rf.noarch.rpm: Header V3 DSA signature: NOKEY, key ID 6b8d79e6
    error: Failed dependencies:
            perl(Net::SNMP) is needed by munin-node-1.2.5-1.el5.rf.noarch
            sysstat is needed by munin-node-1.2.5-1.el5.rf.noarch
    [[email protected] src]# 
    I'm not sure why the the dependencies aren't being automatically installed.

    Any advice would really be appreciated!!!!

    Thanks!

    Tfunk
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Can you try
    Code:
    yum install perl-Net-SNMP
    ?
     
  6. tfunky

    tfunky New Member

    hmmmm.....

    Code:
    [[email protected] ~]# yum install perl-Net-SNMP
    Loading "installonlyn" plugin
    Setting up Install Process
    Setting up repositories
    Reading repository metadata in from local files
    Excluding Packages from CentOS-5 - Base
    Finished
    Excluding Packages from CentOS-5 - Updates
    Finished
    Excluding Packages from CentOS-5 - Addons
    Finished
    Excluding Packages from Elastix RPM Repository for CentOS
    Finished
    Excluding Packages from CentOS-5 - Extras
    Finished
    Parsing package install arguments
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Package perl-Net-SNMP.noarch 0:5.2.0-1.2.el5.rf set to be updated
    --> Running transaction check
    --> Processing Dependency: perl(Crypt::DES) for package: perl-Net-SNMP
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Package perl-Crypt-DES.i386 0:2.05-3.2.el5.rf set to be updated
    --> Running transaction check
    
    Dependencies Resolved
    
    =============================================================================
     Package                 Arch       Version          Repository        Size
    =============================================================================
    Installing:
     perl-Net-SNMP           noarch     5.2.0-1.2.el5.rf  rpmforge           96 k
    Installing for dependencies:
     perl-Crypt-DES          i386       2.05-3.2.el5.rf  rpmforge           37 k
    
    Transaction Summary
    =============================================================================
    Install      2 Package(s)
    Update       0 Package(s)
    Remove       0 Package(s)
    
    Total download size: 133 k
    Is this ok [y/N]: y
    Downloading Packages:
    warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 6b8d79e6
    
    
    Public key for perl-Crypt-DES-2.05-3.2.el5.rf.i386.rpm is not installed
    


    It doesn't seem to be installing do to not having a public key for perl-Crypt-DES....
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Try this:
    Code:
    rpm --import http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt
     
  8. tfunky

    tfunky New Member

    that did the trick! Thank you!

    How did you know that command? It seems I should have been able to google and find it, but I wasn't able to.

    How did you know that was the way to correct that problem?
     
  9. falko

    falko Super Moderator ISPConfig Developer

    I googled for something like "rpmforge key" or so. :)
     

Share This Page