multiviews not working

Discussion in 'Installation/Configuration' started by Stown, Jun 24, 2009.

  1. Stown

    Stown ISPConfig Developer ISPConfig Developer

    Hi,

    My setup is Centos 5.3 ispconfig 3 all working.

    Only i upload a script what i made with multiviews and it is not working.

    Also i added Multiviews to the /etc/httpd/conf/httpd.conf file but it is not working.

    And if i set a .htaccess file i get a internal error on the screen?

    Can anybody help me?

    Thanks
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post the exact error messages that you get in the error log of the website.
     
  3. Stown

    Stown ISPConfig Developer ISPConfig Developer

  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post the exact error messages that you get in the error log of the website.
     
  5. wouterw

    wouterw New Member

    Add this in you website domain Options in ISPconfig with the correct paths:

    Code:
        <Directory /home/www/mydomain.com/web>
            Options +MultiViews
        </Directory>
        <Directory /home/www/clients/client1/web1/web>
            Options +MultiViews
        </Directory>
     
  6. Stown

    Stown ISPConfig Developer ISPConfig Developer

    Is not working.. same problem
     
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    As long as you refuse to post the exact error messages from the error log of the website, we will not be able to help you!
     
  8. Stown

    Stown ISPConfig Developer ISPConfig Developer

    This is some of the last things in the error.log of that website.

    [Thu Jun 25 17:51:05 2009] [error] [client 86.83.234.237] File does not exist: /var/www/clients/client2/web1/web/index, referer: http://www.eertwegh.nl/
    [Thu Jun 25 17:51:05 2009] [error] [client 86.83.234.237] File does not exist: /var/www/error/404.html, referer: http://www.eertwegh.nl/
    [Thu Jun 25 17:56:08 2009] [error] [client 86.83.234.237] File does not exist: /usr/share/squirrelmail/src/favicon.ico
    [Thu Jun 25 17:56:08 2009] [error] [client 86.83.234.237] File does not exist: /var/www/error/404.html
    [Thu Jun 25 18:02:18 2009] [error] [client 86.83.234.237] File does not exist: /var/www/clients/client2/web1/web/index, referer: http://www.eertwegh.nl/
    [Thu Jun 25 18:02:18 2009] [error] [client 86.83.234.237] File does not exist: /var/www/error/404.html, referer: http://www.eertwegh.nl/
    [Thu Jun 25 18:02:19 2009] [error] [client 86.83.234.237] File does not exist: /var/www/clients/client2/web1/web/index, referer: http://www.eertwegh.nl/
    [Thu Jun 25 18:02:19 2009] [error] [client 86.83.234.237] File does not exist: /var/www/error/404.html, referer: http://www.eertwegh.nl/
    [Thu Jun 25 18:02:19 2009] [error] [client 86.83.234.237] File does not exist: /var/www/clients/client2/web1/web/index, referer: http://www.eertwegh.nl/
    [Thu Jun 25 18:02:19 2009] [error] [client 86.83.234.237] File does not exist: /var/www/error/404.html, referer: http://www.eertwegh.nl/
    [Thu Jun 25 18:02:19 2009] [error] [client 86.83.234.237] File does not exist: /var/www/clients/client2/web1/web/index, referer: http://www.eertwegh.nl/
    [Thu Jun 25 18:02:19 2009] [error] [client 86.83.234.237] File does not exist: /var/www/error/404.html, referer: http://www.eertwegh.nl/
    [Thu Jun 25 18:02:20 2009] [error] [client 86.83.234.237] File does not exist: /var/www/clients/client2/web1/web/index, referer: http://www.eertwegh.nl/
    [Thu Jun 25 18:02:20 2009] [error] [client 86.83.234.237] File does not exist: /var/www/error/404.html, referer: http://www.eertwegh.nl/
    [Thu Jun 25 18:02:22 2009] [error] [client 86.83.234.237] File does not exist: /var/www/clients/client2/web1/web/index

    Can it have something to do with this?

    [root@server1 web1]# service httpd restart
    Stopping httpd: [ OK ]
    Starting httpd: [Thu Jun 25 18:02:14 2009] [warn] NameVirtualHost 213.163.64.10:80 has no VirtualHosts
    [Thu Jun 25 18:02:14 2009] [warn] NameVirtualHost 213.163.64.100:443 has no VirualHosts
    [Thu Jun 25 18:02:14 2009] [warn] NameVirtualHost 213.163.64.101:80 has no VirtalHosts
    [Thu Jun 25 18:02:14 2009] [warn] NameVirtualHost 213.163.64.101:443 has no VirualHosts
    [Thu Jun 25 18:02:14 2009] [warn] NameVirtualHost 213.163.64.99:443 has no VirtalHosts
    [Thu Jun 25 18:02:14 2009] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Thu Jun 25 18:02:14 2009] [warn] NameVirtualHost *:80 has no VirtualHosts
    [ OK ]
     
    Last edited: Jun 25, 2009
  9. wouterw

    wouterw New Member

    * Can you confirm that the given Apache directives have been written to /etc/httpd/conf/sites-available/eertwegh.nl.vhost?
    * Do the directories in this directive correspond with the real system paths?
     
  10. dzudzu

    dzudzu New Member

    Also i would point out that if you used ifmodule in vhost file that you verify that module is present becouse <ifmodule something> ... </ifmodule> won't be processed if that module does not exist for apache
     
  11. Stown

    Stown ISPConfig Developer ISPConfig Developer

    Yes, it works! Thank you all.

    I nano'd my /etc/httpd/conf/sites-available/eertwegh.nl.vhost first and added multiviews for the symlink location: /var/www/eertwegh.nl/web and that didnt worked.

    Now i added multiviews to the second directory path what is a full path. /var/www/clients/client2/web1/web. And that worked for me!

    See:

    <Directory /var/www/eertwegh.nl>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <VirtualHost 213.163.64.99:80>
    DocumentRoot /var/www/clients/client2/web1/web

    ServerName eertwegh.nl
    ServerAlias *.eertwegh.nl
    ServerAdmin webmaster@eertwegh.nl

    ErrorLog /var/log/ispconfig/httpd/eertwegh.nl/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/eertwegh.nl/web>
    Options FollowSymLinks MultiViews
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client2/web1/web>
    Options FollowSymLinks MultiViews
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    </Directory>

    # php as cgi enabled
    ScriptAlias /php5-cgi /var/www/php-cgi-scripts/web1/php-cgi-starter
    Action php5-cgi /php5-cgi
    AddHandler php5-cgi .php .php3 .php4 .php5
    <Directory /var/www/php-cgi-scripts/web1/>
    Order allow,deny
    Allow from all
    </Directory>


    </VirtualHost>
     
  12. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Never edit this file manually, all manual changes will be remove. Instead add your changes to the apache directives filed of the site in ISPConfig.
     
  13. Stown

    Stown ISPConfig Developer ISPConfig Developer

    You mean this file? /usr/local/ispconfig/server/conf/vhost.conf.master
     
  14. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    There's a field called "Apache Directives" for each web site in ISPConfig. Use this to add your custom directives - don't edit any files.
     
  15. Stown

    Stown ISPConfig Developer ISPConfig Developer

    i placed followed into ispconfig site configuration and it works:

    <Directory /var/www/clients/client2/web1/web>
    Options MultiViews All
    </Directory>

    This is the right structure to solve this problem?
     
  16. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Should be ok. :)
     
  17. Stown

    Stown ISPConfig Developer ISPConfig Developer

    Why does this solution not work anymore with the latest svn installation? I must have MultiViews on
     
  18. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    There has nothing been changed in SVN lately. Most likely you used a wrong path in the directory staement. Take a look at the vhost file and make sure that the path you use is identical with the path of the vhost.
     
  19. Stown

    Stown ISPConfig Developer ISPConfig Developer

    EDIT: Solved! I had to chmod the web dir to 777 and then the 403 errors went away.

    Look at my vhost: I've tried everything.. It loads the defaut index.php but when i go to eertwegh.nl/index/algemeen it says 403 forbidden.

    <Directory /var/www/eertwegh.nl>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <VirtualHost 213.163.64.99:80>
    DocumentRoot /var/www/clients/client1/web1/web

    ServerName eertwegh.nl
    ServerAlias *.eertwegh.nl
    ServerAdmin webmaster@eertwegh.nl

    ErrorLog /var/log/ispconfig/httpd/eertwegh.nl/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/eertwegh.nl/web>
    Options FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client1/web1/web>
    Options FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    # php as cgi enabled
    ScriptAlias /php5-cgi /var/www/php-cgi-scripts/web1/php-cgi-starter
    Action php5-cgi /php5-cgi
    AddHandler php5-cgi .php .php3 .php4 .php5
    <Directory /var/www/php-cgi-scripts/web1/>
    Order allow,deny
    Allow from all
    </Directory>


    </VirtualHost>
     
    Last edited: Oct 4, 2009

Share This Page