Multiservers Not Updated + Remove Lock

Discussion in 'Installation/Configuration' started by DreamK, Jun 4, 2010.

  1. DreamK

    DreamK New Member

    Hi,

    Sorry to mind you, I have not sleeped since 48 h ;) for trying a solution to my problem.

    My network :

    2 adsl
    2 router for roundrobin
    2 servers
    3 nic on each server (192.168.10.xxx, 192.168.20.yyy, 10.0.0.zzz)

    The Master :

    hostname -f = master.domain.com

    Works perfectly whit ISP3 when it is alone :

    When I install the slave :

    hostname -F = slave.domain.com


    I obtain the following message :


    - master :

    - on slave : nothing updated and this message :


    My configuration from : nano /usr/local/ispconfig/server/lib/config.inc.php


    -------------- slave ---------------------


    --------- master ----------------------------

    mySQL Grant

    I really thank you in advance for sharing your experience.
     
    Last edited: Jun 4, 2010
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Your problem is the max files setting in Linux. Currently, trhe kernel does not allow to open any new files and this causes ispconfig to fail. See here on how to increase the number of open files in Linux:

    http://www.cyberciti.biz/faq/linux-increase-the-maximum-number-of-open-files/

    As a sidenote, you posted errors from the interface on the slaves. Slaves may not run a interface. If you would login to the interface on the slave and add or change something, it will corrupt the database. So never enable the interface on a slave server, a interface shall be installed only on the master.
     
  3. DreamK

    DreamK New Member

    Thanks Till, your reply really helps me.

    I give you some information cause i don t manage to obtain a slave synchro




















    slave-machine:~# /etc/init.d/apache2 restart
    Restarting web server: apache2 ... waiting .


    I check, and i come back ;)
     
  4. DreamK

    DreamK New Member

    Hi ;)

    I have have solved the trouble following the apache-error.log :)

    1/ the slave have not enought right to the master dbispconfig database
    2/ I have changed the default directory location of /var/www -> /home/xxx and /var/vmail -> hard another drive


    Evrything seems to work fine :)

    To understand the right permissions for each database and user :

    Master -> Slave full acces @ slave.domain.com
    Slave -> Master reade insert @ master.domain.com

    Thanks a lot for this great script, I will be happy to show you my new servers ;)

    A donation would be possible for helping the script to be developped ?



    For information : When there is a cron request there is no more access to the CP, it s a correct processus ? (ie8 : AJAX ERROR and in fact I have made an php -q update.php for not doing a reboot)

     
    Last edited: Jun 5, 2010
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The ISPConfig installer sets all permissions correctly on the master server. So just use the ispconfig installer in expert mode to install the slave and never edit any permissions manually as this may cause severe security problems. Before you install the slave, make sure that you create a root user on the master that allows access from the IP AND hostanme of the slave. This root account is just used during install and the password is not stored anywhere on the slave server.

    If you like to help the ispconfig project, please order a howtoforge subscription:

    http://www.howtoforge.com/subscription
     

Share This Page