Multiserver with IPv6 not synchronize [SOLVED]

Discussion in 'ISPConfig 3 Priority Support' started by SupuS, Nov 19, 2018.

  1. SupuS

    SupuS Member HowtoForge Supporter

    Hi all,
    We have 2 servers (master web server + ispconfig and slave mail server) in multiserver setup. I added IPv6 addresses and everything works except synchronization between servers. When I add mailbox it still wait in the queue. I created new mysql user ispcsrv2 on the master server with IPv6 address of slave server which solved the error "mysqli_connect(): (28000/1045): Access denied" but synchronization still not work. When I turn on debuging there is no error in cron.log. When I remove IPv6 addresses from servers config the synchronization works again.
    What did I overlook? Any idea please?
     
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    i think, there is no ispcsrvX-user in the mysql-database for the ipv6-address. make sure, that you added the servers to /etc/hosts with ipv4 and ipv6
     
  3. SupuS

    SupuS Member HowtoForge Supporter

    Hi Florian,
    problem was with privileges of ispcsrvX-user. I copied user with IPv4 address (created by ISPConfig) to new one with changing of IPv4 to IPv6 so I was able to connect to database from slave to master. But it was not sufficient. I had to copy privileges from IPv4 user to IPv6 user manually and synchronization started to work.
    Thank you for your time.
     

Share This Page