Multiserver setup

Discussion in 'ISPConfig 3 Priority Support' started by dpetrek, Apr 13, 2017.

  1. dpetrek

    dpetrek New Member HowtoForge Supporter

    We have two ISPConfig installations, one being 3.0.5.4p2, the other one (fresh) 3.1.2.
    When installing 3.1.2, multiserver setup was not chosen, instead ISPConfig was installed in single-server mode.
    Is it possible to attach this new installation to older ISPConfig now? We would like to use new installation as secondary DNS for some domains.
    How would one do it?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The servers have to be connected during install, you can't attach them later. And both systems must have the same ISPConfig version, so the old system needs to be updated first to 3.1.2, then reinstall ISPconfig on the new system and choose expert mode during install, the installer will ask then if the system shall be connected to a master.
     
  3. dpetrek

    dpetrek New Member HowtoForge Supporter

    ok What if I have two virtual machines with 3.1.2 already installed (fresh install) in single server mode.
    Can I attach them somehow?
    When I run
    php -q install.php
    I get "ISPConfig 3 installation found."
    php -q update.php
    does not allow me to attach...
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If you did not add any websites or other things in ISPConfig on the nodes that shall be added, then proceed like this:

    1) run the uninstall.php script which you can find in the same folder where install.php and update.php are.
    2) Check with e.g. phpmyadmin, that the ispconfig mysql user and the dbispconfig database have been removed. If they are still there, delete them.
    3) run the ISPConfig install.php script, choose expert mode and reinstall ISPConfig like that.

    And one prerequisite, the installer will connect to the master server as MySQL root user, ensure that you have added a root user in mysql on the master that is able to connect from the IP and hostname of the slaves.
     
  5. dpetrek

    dpetrek New Member HowtoForge Supporter

    OK i've managed to set up as you suggested.
    The servers are connected now, hosting2 being the master, hosting3 slave.
    I can setup everything from hosting2 web interface, as expected, however when new database is created (via web interface on hosting2) on hosting3, phpmyadmin link points to hosting2, not hosting 3?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You can use the [SERVERNAME] variable in the phpmyadmin url field under System > Interface > Main config. Example:

    http://[SERVERNAME]/phpmyadmin
     
    dpetrek likes this.

Share This Page