Multiserver Setup, Webserver create DB and dbuser but not created on MySQL server

Discussion in 'General' started by alkpone, Dec 18, 2010.

  1. alkpone

    alkpone New Member

    I followed all the Multiserver setup Manual, I installed the web server and The MySQL server.But When I create a Database with the Admin panel phpmyadmin doesn't recognise the user.

    I checked the mysql sever but It does not show the user and DB created with the Admin panel;

    Both server are usign ISPconfig 3.0.3.1.
     
  2. Ghostdare

    Ghostdare Member

    Try to create database from inside ISP Config interface, not directly from phpmyadmin web interface.
     
  3. alkpone

    alkpone New Member

    Thanks for you reply GhostDare.

    Actually I created two DB using Ispconfig Panel, but these domains cannot be accessed from their own phpmyadmin:
    Ex:

    www.domain1.com/phpmyadmin
    www.domain2.net/phpmyamin

    I write the user and pass I created within ISPconfig panel, but get error "#1045 - Access denied for user 'c2userXX'@'localhost' (using password: YES)", I think phpmyadmin is right, because I created these db and user for mysql.domain.com and no for web.domain.com.

    Actually I don't know how to point phpmyadmin to access to mysql.domain.com. When users want to make changes to their own databases.

    I did almost everything as the Multiserver setup say....The only things I haven't done yet is create the dns according to the manual. I am using other DNS.

    Can this DNS thing be causing the problem?.

    Ps: Both Domains are accessible from anywhere, so I think the dns is fine.

    Thanks in advance.
     
    Last edited: Dec 18, 2010
  4. mbsouth

    mbsouth New Member

    On which server did you installed the databases? Webserver or sqlserver?
    Does phpMyAdmin connecting the right server?

    You can find more infos here: phpMyAdmin and multiserver




    mbsouth
     
  5. alkpone

    alkpone New Member

    Hi, Thanks for you reply.

    Actually according to the ISPconfig3 I have two servers named as follow, web.domain.com (Wich contain ISPconfig Panel, PHPmyadmin, Apache2, MySQL)
    and mysql.domain.com (Wich is slave to web.domain.com and only run MySQL) this server (mysql.domain.com) is supposed to serve mysql databases to costumers.

    As I mentioned before I can create DB from my ISPconfig Panel but none of my clients can Access to the their DB using PHPmyadmin.

    My clients can access to phpmyadmin via http://clientsDomain.com/phpmyadmin

    But once they write their username and password They get Worng Pass Error.
     
  6. mbsouth

    mbsouth New Member

    It seems that
    thats absolutly ok.

    Read my post above, follow the link, study and configure phpMyAdmin for multiserver and it´ll works!


    mbsouth
     
  7. outeredge

    outeredge New Member

  8. alkpone

    alkpone New Member

    Of Course It make sense... The problem is ISPconfig is not working that way.. I haved followed the last recommendation.. It works, now PHPmyadmin allow to switch between servers...

    But the problem persist, User can not access to their database... ISPcofig create them in the panel... But I cannot access via web.domain.com or mysql.domain.com. I don´t know where ispconfig is sending or creating the databases..

    I have checked the Logs, But I have not found any problem. I have maked a "netstat -tap | grep mysql" on the mysql.domain.com and It shows the connections between servers (web.domain.com & mysql.domain.com)...

    Actually I have changed the "localhost" by "mysql.domain.com" as tut recommend but it still has the same problem.

    I have been reading on the net.. When i find a solution I am gonna post it here...
     
  9. vogelor

    vogelor ISPConfig Developer ISPConfig Developer

    i am wondering, if you have a problem with your multiserver-setup.

    if you create a web at the second server (not the server, der ISPConfig-Panel is running at) - is the new web been created or not?

    Oliver
     
  10. alkpone

    alkpone New Member

    Hi Vogelor, thanks for replaying.

    Actually I have two server setup.

    One as my webserver named:
    web.domain.com (With Apache and ISPconfig panel running on it)

    The other one named:
    mysql.domain.com (Only host mysql databases).

    I actually can Host any web. The DNS is working resolving both names.. Or maybe the problem is with DNS?
     
  11. vogelor

    vogelor ISPConfig Developer ISPConfig Developer

    i understand your settings, but that was not the answer of my question.
    i am wondering, if your multiserver-setup is ok.
    i want to know, if the ipsconfig-setup of your server2 (in your case your db-server) was right and if your server2 can interact with your ISPConfig-Interface. if not, no database is created and no other actions (like creating a new web a ftp user and so on...) are done.

    so please try to add another web at your server2 ( i know, your server is only for databases, but the web is for testing only) and tell my, if this web is created (if not, the communication between your servers is broken)

    oliver
     
  12. alkpone

    alkpone New Member

    Thanks Oliver .

    Yes, I was able to create a web site using ISPconfig on server2.
     
    Last edited: Dec 21, 2010
  13. vogelor

    vogelor ISPConfig Developer ISPConfig Developer

    ok . that means, that the communication between the servers works fine and that the server2 is able to create a database or something else.

    next step:
    please login at server2 (shell) and connect to the local mysql as user root.
    then type
    show databases;

    can you see the new databases?
    do NOT use phpmyadmin, connect to the database within the shell!
     
  14. alkpone

    alkpone New Member

    Yes the databases are created on the server...And the comunication between server working fine.
     
  15. vogelor

    vogelor ISPConfig Developer ISPConfig Developer

    ok - lets do the next step ;-)

    the phpmyadmin is at server1 - right?

    if so, you can't connect the database at server2 with phpmyadmin running at server1 - correct?

    f so, login into the ISPConfig panel and check the remote-access checkbox at the database you created.

    wait one minute and try the connection again.

    tell me, what happens...

    Oliver
     
  16. alkpone

    alkpone New Member

    1- Yes PHPmyadmin is at server1.
    2- No, I cannot connect with phpmyadmin to db on server2.
    3- I login, checked remote-access.
    4- Phpmyadmin don´t let me in... But I can login using the shell.

    Thanks in advance Vogelor--- I aprecciate your help.
     
  17. vogelor

    vogelor ISPConfig Developer ISPConfig Developer

    sorry. from now on i cant help you...

    everything with ispconfig and your multiserver-setup works fine.
    server2 is able to create the database like the control-panel at server1 tells him.

    this is a problem of mysql or a wrong configuration of phpmyadmin.
    (or of cource a problem of your firewall)

    if you can speak german, maybe this link will help you.
    http://www.little-idiot.de/mysql/mysql-108.html

    if not please google for
    Code:
    mysql "-h hostname" 
    or
    Code:
    mysql connect to remote server
    or
    Code:
    mysql connect to another server
    i hope, this will help you
     
  18. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    Code:
    netstat -tap
    and
    Code:
    iptables -L
    on server2?
     
  19. alkpone

    alkpone New Member

    Problem Solver

    Thanks Guys! The Problem is solved, Using the phpmyadmin Multiserver setup, recommended by Mbsouth, Thank vogelor for you patient and support.

     
  20. vogelor

    vogelor ISPConfig Developer ISPConfig Developer

    My pleasure :D
     

Share This Page