Multiserver setup mail() problem

Discussion in 'Installation/Configuration' started by DKLeader, Jun 17, 2012.

  1. DKLeader

    DKLeader New Member

    Hi,

    I am running vers 3.0.4.5 in a multiserver setup on Debian.

    When users install i.e. WEBSpell or PHPFusion mail() does not work.

    I have checked with different logs on the servers to see if I could find a reason for this.

    The solutions I have found searching google only gave hints for single server but not when running on a multiserver setup.

    Anyone got a hint to what to do / change?
     
  2. till

    till Super Moderator

    Ensure that you installed at least a minimal webserver like postfix or exim listening on localhost on the server so that php can send emails.
     
  3. DKLeader

    DKLeader New Member

    I do have postfix running on the webserver.
    Code:
    web:/etc/postfix# /etc/init.d/postfix check
    web:/etc/postfix#
    If I do a restart :
    Code:
    web:/etc/postfix# /etc/init.d/postfix restart
    Stopping Postfix Mail Transport Agent: postfix.
    Starting Postfix Mail Transport Agent: postfix.
    web:/etc/postfix#
    From ps aux | grep postfix
    Code:
    root      3132  0.0  0.0   8368   756 ?        Ss   Mar16   0:00 /usr/sbin/saslauthd -a shadow -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root      3133  0.0  0.0   8368   476 ?        S    Mar16   0:00 /usr/sbin/saslauthd -a shadow -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root      3135  0.0  0.0   8368   360 ?        S    Mar16   0:00 /usr/sbin/saslauthd -a shadow -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root      3137  0.0  0.0   8368   360 ?        S    Mar16   0:00 /usr/sbin/saslauthd -a shadow -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root      3139  0.0  0.0   8368   360 ?        S    Mar16   0:00 /usr/sbin/saslauthd -a shadow -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root     25157  0.0  0.0   5628  1848 ?        Ss   21:48   0:00 /usr/lib/postfix/master
    postfix  25158  0.0  0.0   5640  1816 ?        S    21:48   0:00 pickup -l -t fifo -u -c
    postfix  25159  0.0  0.0   8028  2360 ?        S    21:48   0:00 qmgr -l -t fifo -u
    postfix  25188  0.0  0.0   6008  2628 ?        S    21:49   0:00 tlsmgr -l -t unix -u -c
     
  4. falko

    falko Super Moderator

    Are there any errors in the web server's mail log?
     
  5. DKLeader

    DKLeader New Member

    As I see it it seems that everything is ok but the e-mails are never delivered. I have noticed that an error related to amavis.
    From the mail.log :
    Code:
    Jun 30 20:36:40 web postfix/pickup[17448]: 9BB7E3EC4A0: uid=33 from=<www-data>
    Jun 30 20:36:40 web postfix/cleanup[17682]: 9BB7E3EC4A0: message-id=<20120630183640.9BB7E3EC4A0@web.superweb.dk>
    Jun 30 20:36:40 web postfix/qmgr[26057]: 9BB7E3EC4A0: from=<www-data@SuperWebServer10.superweb.dk>, size=467, nrcpt=1 (queue active)
    Jun 30 20:36:40 web amavis[18021]: (18021-09) NOTICE: reconnecting in response to: err=2006, HY000, DBD::mysql::st execute failed: MySQL server has gone away at (eval 86) line 166, <GEN117> line 3.
    Jun 30 20:36:41 web postfix/smtpd[17687]: connect from localhost[127.0.0.1]
    Jun 30 20:36:41 web postfix/smtpd[17687]: D651B3EC049: client=localhost[127.0.0.1]
    Jun 30 20:36:41 web postfix/cleanup[17682]: D651B3EC049: message-id=<20120630183640.9BB7E3EC4A0@web.superweb.dk>
    Jun 30 20:36:41 web postfix/qmgr[26057]: D651B3EC049: from=<www-data@SuperWebServer10.superweb.dk>, size=913, nrcpt=1 (queue active)
    Jun 30 20:36:41 web postfix/smtpd[17687]: disconnect from localhost[127.0.0.1]
    Jun 30 20:36:41 web amavis[18021]: (18021-09) Passed CLEAN, <www-data@SuperWebServer10.superweb.dk> -> <jg@voiceme.dk>, Message-ID: <20120630183640.9BB7E3EC4A0@web.superweb.dk>, mail_id: l1veNvoXY$
    Jun 30 20:36:41 web postfix/smtp[17684]: 9BB7E3EC4A0: to=<jg@voiceme.dk>, relay=127.0.0.1[127.0.0.1]:10024, delay=1.3, delays=0.08/0.02/0/1.2, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=18021-09, fr$
    Jun 30 20:36:41 web postfix/qmgr[26057]: 9BB7E3EC4A0: removed
    Jun 30 20:36:41 web postfix/pipe[17688]: D651B3EC049: to=<jg@voiceme.dk>, relay=maildrop, delay=0.1, delays=0.03/0.02/0/0.05, dsn=2.0.0, status=sent (delivered via maildrop service)
    Jun 30 20:36:41 web postfix/qmgr[26057]: D651B3EC049: removed
    
     
  6. falko

    falko Super Moderator

    Seems as if there's a problem with your MySQL server. Did you check your syslog for MySQL error? MySQL problems can also originate from not having enough RAM or a high system load.
     

Share This Page