Multiserver Setup - ERROR: Database...

Discussion in 'Installation/Configuration' started by Rapid2214, Jun 2, 2010.

  1. Rapid2214

    Rapid2214 New Member

    Hi all,
    I having this problem: ERROR: Stopped: Database already contains some tables. On my secoundry server :( .
    I type 'y' for 'Shall this server join...' and just hit enter for the default database name.
    Worked fine on my Virtual Mechines but in the real world it isn't working :rolleyes:

    Thanks in advance,


    PS Primary server is working fine...
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The error means that there is already a database with that name on the slave server which contains database tables. Please delete that database on the slave before you install ispconfig on it. Also be sure that you have not accidently entered the login details for the master database when you got asked for the local mysql db. The details for the master are asked later after you selected to join a master server.
  3. Rapid2214

    Rapid2214 New Member

    Thanks now im getting the following output, note im using a new user called 'remotesys' because i had problems with root remotly, i have granted remotesys all privilges

    Adding ISPConfig server record to database.

    ERROR: Unable to create database user in master database: ispcsrv2 Error: GRANT command denied to user 'remotesys'@'' for table 'server'
  4. Rapid2214

    Rapid2214 New Member

    Fixed it, the user needed to be able to GRANT:

        -> ON *.*
        -> TO [email protected]
        -> IDENTIFIED BY 'newpassword'
    Thanks for your help

Share This Page