Multiserver Prolem / Salve doesnt get updated (jobqeue)

Discussion in 'Installation/Configuration' started by MM-, Jul 10, 2009.

  1. MM-

    MM- New Member

    Hi all,

    i did install a Multiserver setup with some information i did gathered on this forum. What i did was:

    1) Install normal ISPCONFIG Masterserver
    2) Install expert installation on Slave
    db > localhost
    masterserver db > x.x.x.x
    ISPCONFIG Interface on Slave > Choose no

    After looking at the Jobqeue (on the Masterserver), i saw it just gets filled with Updates for the Slave.

    The ispconfig.log on both server is empty.

    How can i debug this problem?

    PS: If anybody has some notes about the "Replication", that would be great.

  2. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Try to enable verbose log in the ispconfig server config (/usr/local/ispconfig/server/lib/ on both the master and slave
    $conf["log_priority"] = 0
    Check if running
    gives any errors.
  3. MM-

    MM- New Member

    Sorry i had much todo and didnt dig into it.

    After checking the log, i found this very clear message:
    WARNING - DB::connect()-> mysql_connect Access denied for user 'ispcsrv5'@''
    SELECT * from user on master, shows that the user is added but with the worng ip / hostname.

    The problem is caused by wrong entry's in /etc/hosts.
  4. MM-

    MM- New Member

    By the way, this message seems more then a WARNING log message :eek:)
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You will have to correct the settings in the hosts file and then correct the permission records (allowed hsos) for the user ispcsrv5 in the mysql master database table.
  6. MM-

    MM- New Member

    yeah i did that and ispconfig runs now very nicely. (forgot to say that after figuring out the problem:))

    Again, shouldn't this message be rated as ERROR? :confused:
    If yes, should i report a bug?

Share This Page