Multiserver ISPConfig Setup - Only 1 server serving requests [not firewall issue]

Discussion in 'HOWTO-Related Questions' started by bjtrammell, Feb 29, 2016.

  1. bjtrammell

    bjtrammell New Member

    So I have two ISPConfig servers. Master/Slave setup. ** For this post I'll be using Private IP Addresses, but the servers have public ones **
    Both servers were setup at the same time, with the same information. When I originally loaded all my files on the master, I expected them to be replicated to the slave, they were not. Checked the ISPConfig script for errors. Which is fine. Now that seems to have resolved itself.

    The problem now is that I have two servers, and only one is actually serving requests (master). Both servers have public IP addresses (for security I have omitted the Public IP's and exact hostname's of the servers, for obvious reasons).

    Here's what I know so far:
    • The issue is NOT related to a port or firewall problem. I've checked MXToolbox, YouGetSignal and several other tools. All required ports for the slave are OPEN.
    • Apache is running on the slave with no errors, same with DNS, SMTP, POP, IMAP, etc. All services show as running for both servers in ISPConfig3.
    • There are no errors being logged in any of the log files. Traffic is just not being sent to the slave.
    • The name server is setup as follows: [], []
    • Named is serving requests on the slave, but for some reason only pointing traffic to master for everything but DNS.
    • A records are created for both hosts on the master and slave for the root domain name, and www, as well as wildcard records. pointing to the public ip addresses of both servers.
    I have no idea where to go from here, or what could be causing it. I want to get this solved as I'm going to be setting up a third server in the coming days and don't want to run into the same issue (and if I do I need to know how to resolve it).

    Any additional help would be appreciated. (Btw, I'm not a newb, please don't treat me like one ;))
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    A Multiserver mirror means that all servers CAN serve the results and not that they actually DO serve them. If you want the traffic to be splitted to all available nodes, you need a load balancer or a firewall that splits the traffic to all nodes or you need at least round robin dns records.
  3. bjtrammell

    bjtrammell New Member

    Thank you for your post Till. I actually resolved this issue myself.
    Round Robin is enabled on the Domain and pointed at both servers.

    This thread can be closed/deleted.

Share This Page