multiserver install errors

Discussion in 'Installation/Configuration' started by Tomislav Aurednik, Apr 1, 2017.

  1. Tomislav Aurednik

    Tomislav Aurednik Member HowtoForge Supporter

    I'm trying to create a HA multiserver setup. But I'm running into problems and errors.
    My 1st pair of nodes:,, the floating IP and its hostname Installed #1 node normally, shot it down so the servicer were running on #2 node, deleted the ispconfig table and installed again.

    My 2nd pari of nodes:,, the floating IP and its hostname
    Added the user for the 2nd pair of nodes with floating IP and hostname but during the install it wanted to connect with the nodes IP and hostname and not with the floating IP and hostname so it couldn't connect.
    So I created a user for both nodes hostname and IP. The install went through all the db info but throw errors:

    PHP Fatal error: Uncaught Error: Call to undefined function mb_detect_encoding() in /tmp/ispconfig3_install/install
    Stack trace:
    #0 /tmp/ispconfig3_install/install/lib/mysql.lib.php(146): db->escape('dbispconfig')
    #1 /tmp/ispconfig3_install/install/lib/mysql.lib.php(228): db->_build_query_string('CREATE DATABASE...', 'dbispconfi
    g', 'utf8')
    #2 /tmp/ispconfig3_install/install/lib/mysql.lib.php(267): db->_query('CREATE DATABASE...', 'dbispconfig', 'utf8')
    #3 /tmp/ispconfig3_install/install/lib/installer_base.lib.php(237): db->query('CREATE DATABASE...', 'dbispconfig', '
    #4 /tmp/ispconfig3_install/install/install.php(290): installer_base->configure_database()
    #5 {main}
    thrown in /tmp/ispconfig3_install/install/lib/mysql.lib.php on line 445

    And before the last error the install failed and I needed to add sql-mode="NO_ENGINE_SUBSTITUTION" to my.cnf.
    Anyone knows how to install multiserver instal with HA nodes? Or just any hint if its possible will do.

Share This Page