multiserver email routing issues

Discussion in 'Installation/Configuration' started by madsage, Nov 2, 2011.

  1. madsage

    madsage New Member

    I setup multiserver debian v6 and ispconfig 3.03

    the mail server has dovecot and postfix,
    while the web server has exim and configured to smart relay to mail server.

    I test via shell sending email form webserver to mailserver and relay is accepted and sends local email to external host fine.

    However if an email is created via apache on hosted website. I cannot find where the mail ends up at all now.

    Any ideas or clues what i should look for?
    btw, it used to bounce before i configured exim smarthost to mailserver.
    and i could find it in /var/mail but no more.. not on the emailhost either. it just disappears now. lol

    madsage
     
  2. madsage

    madsage New Member

    okay i jumped the gun. it appears to be working now.
    only issue is email is sent from [email protected]

    is there a way to change the user? is that a function of how the website forms the email? or how apache is sending it?

    thanks,

    and i ran update ispconfig all servers and they are all now 3.04, very slick guys.
    love how effortlessly that worked!

    madsage
     
  3. pititis

    pititis Member

    Hi,

    you must add some header in your email form or script. Take a look here:

    www.php.net/manual/en/function.mail.php

    And I see that you aren't running fcgi. If you use fastcgi emails will be send with the real owner instead www-data. Change it if you want more control over all emails sent with the mail function.

    Cheers
     

Share This Page