Multiserver backup to 3.0.5.1

Discussion in 'Installation/Configuration' started by beenfishing, Mar 3, 2013.

  1. beenfishing

    beenfishing New Member

    Hi

    I am busy trying to upgrade my production multiserver setup from version 3.0.4.6 to vesrion 3.0.5.1.

    I have started with one of the slave server but I am getting this error, is it normal? Should I carry on upgrading the other slaves and them the master?

    Reconfigure Permissions in master database? (yes,no) [no]: yes

    WARNING: Unable to set rights of user in master database: dbispconfig
    Query: GRANT SELECT, UPDATE (`ssl_request`, `ssl_cert`, `ssl_action`, `ssl_key` ) ON dbispconfig.`web_domain` TO 'ispcsrv5'@'blah'
    Error: Unknown column 'ssl_key' in 'web_domain'
    WARNING: Unable to set rights of user in master database: dbispconfig
    Query: GRANT SELECT, UPDATE ON dbispconfig.`aps_instances` TO 'ispcsrv5'@'blah'
    Error: Table 'dbispconfig.aps_instances' doesn't exist
    WARNING: Unable to set rights of user in master database: dbispconfig
    blahQuery: GRANT SELECT, INSERT, DELETE ON dbispconfig.`web_backup` TO 'ispcsrv5'@' '
    Error: Table 'dbispconfig.web_backup' doesn't exist
    WARNING: Unable to set rights of user in master database: dbispconfig
    Query: GRANT SELECT, UPDATE (`ssl_request`, `ssl_cert`, `ssl_action`, `ssl_key` ) ON dbispconfig.`web_domain` TO 'ispcsrv5'@'blah'
    Error: Unknown column 'ssl_key' in 'web_domain'
    WARNING: Unable to set rights of user in master database: dbispconfig
    Query: GRANT SELECT, UPDATE ON dbispconfig.`aps_instances` TO 'ispcsrv5'@'blah'
    Error: Table 'dbispconfig.aps_instances' doesn't exist
    WARNING: Unable to set rights of user in master database: dbispconfig
    Query: GRANT SELECT, INSERT, DELETE ON dbispconfig.`web_backup` TO 'ispcsrv5'@' blah'
    Error: Table 'dbispconfig.web_backup' doesn't exist
    Reconfigure Services? (yes,no) [yes]: yes

    Any advise would be greatly appreciated.

    Thanks
     
    Last edited: Mar 3, 2013
  2. MaddinXx

    MaddinXx HowtoForge Supporter

    You should first upgrade the master. The errors are because the tables do not yet exist in master's DB - therefor it can't grant permissions.
     
  3. beenfishing

    beenfishing New Member

    Thanks for getting back to me, that's what I thought but the upgrade instructions say that on a multiserver setup you should do the slaves first and thats what I've done in the past.

    Just confirming that I must definitly upgrade the master fisrt?
     
  4. MaddinXx

    MaddinXx HowtoForge Supporter

    I've read both variants - with slave first and the other way around. Personally I always update the master first and never had problems.
     
  5. beenfishing

    beenfishing New Member

    Ok, thanks.

    I have now updated the master and all appeared to go ok, how do I run the update again on the slave that I did first to repair those errors, if I run the update script, it says that it's already on the latest version.
     
  6. diablo666

    diablo666 Member

    Hi beenfishing, i've reading that you had upgraded a multiserver setup.

    I'm ready to update my multiserver setup starting from the master.

    Except the attention on

    Reconfigure Permissions in master database? (yes,no) [no]:

    If this is a slave server in a multiserver setup, then choose “yes” here on at least one of the slave servers. For single server installations, choose ‘no’. Then you were asked if the services shall be reconfigured:


    Al the other default thing shoule be ok?

    Tnx very much for response
     
  7. beenfishing

    beenfishing New Member

    Yes, that is correct, you upgrade the master server fisrt and select no to reconfiguring the database, then you do the slave servers and select yes to reconfiguring the database on all the slave servers.
     
  8. diablo666

    diablo666 Member

    All fine thanks ;)
     

Share This Page