multiple SSL on one ip using SSI

Discussion in 'Installation/Configuration' started by rlischer, Feb 4, 2013.

  1. rlischer

    rlischer Member HowtoForge Supporter

    I am running ISPConfig 3 perfect server Debian Squeeze Nginx setup.

    SSL works fine on https://server.myserver.com using a Godaddy cert, no warnings. I added another site using a Godaddy SSL cert, I checked SSL and SSI pasted in my Godaddy SSL info, but when I access this site, it still uses the other Godaddy cert so I get the warning. How can I make this new site use the other SSL cert? I thought checking SSI would do the trick for newer browsers, but no luck. Keep in mind I only have the one static IP so this is why I am trying SSI.


    Thanks.
     
  2. pititis

    pititis Member

    SSI? No. You must check if SNI is enabled (system->server config->servername->web->SSL settings AND the SSL checkbox in websites.

    And be sure that you select the real ip address instead * in each website

    cheers
     
  3. rlischer

    rlischer Member HowtoForge Supporter

    I was under the impression SSI is what allows multiple SSL certificates to work with one static IP? When I picked the IP, instead of * my site stopped working. I figure that is because the ip was 10.0.0.1, a local lan IP. Maybe I should add the real eternal IP to the server and try it that way?

    thanks
     

Share This Page