multiple server update server.php script

Discussion in 'General' started by SrTango, Oct 15, 2009.

  1. SrTango

    SrTango New Member

    Hi,
    I don't quite get the following
    on server.php script that one that runs every minute you can see something like:
    $server_db_record = $app->db->queryOneRecord("SELECT * FROM server WHERE update = 1 AND server_id = ".$conf["server_id"]);

    but there is no update field on that table the field is actually called updated (probably to avoid using a reserved word in mysql and having to quote or add server.update) anyway I just dont get if I am missing something or this is actually a bug

    mysql> describe server;
    +----------------+---------------------+------+-----+---------+----------------+
    | Field | Type | Null | Key | Default | Extra |
    +----------------+---------------------+------+-----+---------+----------------+
    | server_id | int(11) unsigned | NO | PRI | NULL | auto_increment |
    | sys_userid | int(11) unsigned | NO | | 0 | |
    | sys_groupid | int(11) unsigned | NO | | 0 | |
    | sys_perm_user | varchar(5) | NO | | | |
    | sys_perm_group | varchar(5) | NO | | | |
    | sys_perm_other | varchar(5) | NO | | | |
    | server_name | varchar(255) | NO | | | |
    | mail_server | tinyint(1) | NO | | 0 | |
    | web_server | tinyint(1) | NO | | 0 | |
    | dns_server | tinyint(1) | NO | | 0 | |
    | file_server | tinyint(1) | NO | | 0 | |
    | db_server | tinyint(1) | NO | | 0 | |
    | vserver_server | tinyint(1) | NO | | 0 | |
    | config | text | NO | | NULL | |
    | updated | bigint(20) unsigned | NO | | 0 | |
    | active | tinyint(1) | NO | | 1 | |
    +----------------+---------------------+------+-----+---------+----------------+


    so should I change the script or I am really missing someting?

    Thanks,
     
  2. till

    till Super Moderator

    Looks as if your servers are not up to date. This has been changed in ispconfig some time ago. Please update all your servers to ispconfig 3.0.1.6 which will be released today. Dont use 3.0.1.5 as it contians a bug in the updater for multiserver setups.
     
  3. SrTango

    SrTango New Member

    AHHHHH I knew it.
    I've been fighting the whole day with update issues. The call center hates me, the clients hates them. I had to dump (thank god for '--where' mysqldump parameter) to update some servers.

    In the other hand 3.0.1.5 has some issues with failed updates that ends up clearing your whole database, again, thank god for daily dumps.

    Anyway thank you for your answer I was about to go crazy
     
  4. till

    till Super Moderator

    Thats why we released 3.0.1.6. But the problem occurs only on slaves of multiservers systems and not masters, so you can simply copy the database from the master to the slave, no need to use any backups.
     
  5. SrTango

    SrTango New Member

    Yeah but that will copy the full database which AFAIK is not the idea. (not sure tho, I'm been messing with ispconfig for a few weeks only)
    so when it first happened to me I took the conservative approach of copying the mail_user server mail_forwarding (And a few others that I cant remember) but only where server_id = the server_id of the server I was trying to reconstruct.
    After that I just started making a daily dump and a pre update dump (which I believe is now part of the standard update or I just missed that it was already part of it)

    Anyway it just works now which is always a good thing
     

Share This Page