Multiple PHP versions.

Discussion in 'Installation/Configuration' started by Tekati, Dec 28, 2010.

  1. Tekati

    Tekati Member Moderator HowtoForge Supporter ISPConfig Developer

    Is there a good way to run multiple PHP versions with ISPConfig3? I have an old webmail client which my client wants to keep and does not want to pay to upgrade to the latest version which only supports PHP < 5.3.
     
  2. todx

    todx New Member

    I know this is an old thread, but I'd really like to know if this is possible. Can any of the administrators please answer this thread?
     
  3. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

  4. todx

    todx New Member

    Great! Thanks for the information till. Another question: How hard/easy will it be to add another PHP version?

    EDIT: ** also .. when will ISPConfig 3.0.5 be released? :)
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The ispconfig part is easy, you just add the path to the new php binary in the interface. What might be more complicated is to built a php binary of the desired php version, this differs for each linux distribution but most likely you will have to compile it.

    This year (summer).
     

Share This Page