Multiple PHP versions and ubuntu 16.04 LTS

Discussion in 'Developers' Forum' started by jamby, Aug 21, 2016.

  1. jamby

    jamby New Member

    Hi all!
    I have a big problem. Fresh installed my VPS (dual xeon, 4gb ram, 80gb ssd) perfect server ubuntu 16.04 with ispconfig 3.1RC1.
    Server and domain and all functions is perfect.
    No mail problem, no ftp problem. Momently Ubuntu 16.04 only PHP 7 working. I have many oldest website and need other php versions.
    I probable installing PHP 5.3.29 and 5.4.45 and many compile errors. Never working with oldest documetations (perfect server 12.04 and 13.04 multiple php versions install). Anyone using multiple PHP on ubuntu 16.04? Please help me how to installed it!

    Br. Jam from Hungary
     
  2. Jesse Norell

    Jesse Norell Active Member

    I've not done that on ubuntu 16 offhand, but followed along some of the guides for debian 8 recently. Likely compile problems are just missing dependencies. If you don't find a guide or specific help, of course try google searches, and maybe post the actual error(s) you're getting and someone can help better.
     
  3. Please output the compile errors, as already stated above it is probably just a matter of installing the correct dev- packages.
     
  4. jamby

    jamby New Member

    Hi!
    I think the first error is the Bison version is invalid. Found 3.0.4 and ./compile is need 2.6.4 max. version. Any solution? Downgrading the Bison package? How to make this?
    Br. JaM
     
  5. jamby

    jamby New Member

    configure: warning: bison versions supported for regeneration of the Zend/PHP parsers: 1.28 1.35 1.75 1.875 2.0 2.1 2.2 2.3 2.4 2.4.1 2.4.2 2.4.3 2.5 2.5.1 2.6 2.6.1 2.6.2 2.6.4 (found: 3.0.4).
     
  6. jamby

    jamby New Member

    Hi All.
    PHP 5.3.29 install is not working on ubuntu 16.04. I install php 5.4.45 configure and make and make install completed following the
    How To Use Multiple PHP Versions (PHP-FPM & FastCGI) With ISPConfig 3 (Ubuntu 12.04 LTS)
    One error only after install includes. Memcache is installed and memcached is not.
    :/opt/php-5.4.45/etc# pecl -C ./pear.conf install memcached
    pecl/memcached requires PHP (version >= 5.2.0, version <= 6.0.0, excluded versions: 6.0.0), installed version is 7.0.8-0ubuntu0.16.04.2
    No valid packages found
    install failed
    Anyone isnstalled php 5.4 on ubuntu 16.04?
    Br. JaM
     
  7. Jesse Norell

    Jesse Norell Active Member

    I'm sure you could install memcached from your OS packages, though I have no idea if that memcached is compatible with the memcache support built into your custom php version.
     
  8. Php 7 only supports the module memcached, not memcache.
    If you want memcache for your older PHP versions you need to install that manually. (Compile manually). Install the correct dev-memcache package and download the module from pecl;).
     

Share This Page