Multiple PHP version

Discussion in 'Installation/Configuration' started by diablo666, Mar 18, 2013.

  1. diablo666

    diablo666 Member

    Hi there,
    i've read the tutorial about installing various php version such 5.3.22 here http://www.howtoforge.com/how-to-us...pm-and-fastcgi-with-ispconfig-3-debian-wheezy

    That's ok and works fine.

    I've tried to compile in the same way php 5.

    For compatibility with some old Drupal site, i've tried to compile php-5.2.17 but when i'll lunch

    Code:
    apt-get build-dep php5
    i'll get the error

    Code:
    apache2-prefork-dev : Depends: libaprutil1-dev but it's not going to be installed
    So i tried to install it with

    Code:
    apt-get install libaprutil1-dev
    but i'll get

    Code:
    libaprutil1-dev : Depends: libpq-dev but it's not going to be instelled
    so i tried...

    Code:
    apt-get install libpq-dev
    and there i'll get

    Code:
    libpq-dev : Depends: libpq5 (= 8.4.16-0squeeze1) but version 9.1.4-2~bpo60+1 it's going to be instelled
    I'm using debian 6.0.7

    Code:
    cat /etc/debian_version
    6.0.7
    I't php 5.2.17 too old to be compiled on this linux version?

    Thank you for response.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page