multiple IP addresses

Discussion in 'Installation/Configuration' started by blackflag, Aug 12, 2006.

  1. blackflag

    blackflag New Member

    Hello all,

    I have ispconfig on debian 3.1 installed. I created some websites but only one website is available. Also the IP address are not pingable. I meant I have raed something about a multiple IP issue in the forum. I googled and watched the forum but can not find the information. Or Im wrong?

    can someone help?

    tia
    stefan
     
  2. edge

    edge Active Member Moderator

  3. blackflag

    blackflag New Member

    AFAIK it is not neccesary to add all IPs in /etc/network/interfaces, it should be done in ispconfig. And that is what I did. I can remember that I have to edit a file to make ispconfig able to use multiple IPs. Correct?
    Where and what is it?

    Can someone help?
    tia stefan
     
  4. edge

    edge Active Member Moderator

    I have at the moment 16 IP's (1 real IP and 15 virtual IP's) on my Debiab Sarge 3.1 server, and to make it work I did need to do it that way.
     
  5. stamy

    stamy New Member

    I have almost the same problem.
    My ISP give me a Dynamic IP address for my server connected to Internet, public [email protected]
    I asked for a second IP@ for my server and add it in the right section under ISPConfig, but even after a new server start it is not working.
    So i add this second IP@ manually into the "/etc/network/interfaces" in this way:

    ---------------------- /etc/network/interfaces ------------------------
    auto lo eth0
    iface lo inet loopback

    iface eth0 inet dhcp

    auto eth0:0
    iface eth0:0 inet static
    address 12.34.56.78
    netmask 255.255.255.255
    # network 192.168.0.0
    broadcast 12.34.56.78
    gateway 1.2.3.4
    -----------------------------------------------------------------------

    This is the result now with "ifconfig" command is:

    ------------------------ ifconfig -------------------------------------

    eth0 Link encap:Ethernet HWaddr 00:30:05:BB:A4:38
    inet addr:12.34.56.77 Bcast:12.34.56.77 Mask:255.255.255.255
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:4284 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3417 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:413985 (404.2 KiB) TX bytes:1041817 (1017.3 KiB)
    Interrupt:16 Base address:0x4000

    eth0:0 Link encap:Ethernet HWaddr 00:30:05:BB:A4:38
    inet addr:12.34.56.78 Bcast:12.34.56.78 Mask:255.255.255.255
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    Interrupt:16 Base address:0x4000
    -----------------------------------------------------------------------

    I found the default route with the "route -n" command:

    -------------------------- route -n -----------------------------------
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    1.2.3.4 0.0.0.0 255.255.255.255 UH 0 0 0 eth0
    0.0.0.0 1.2.3.4 0.0.0.0 UG 0 0 0 eth0
    0.0.0.0 1.2.3.4 0.0.0.0 UG 0 0 0 eth0
    -----------------------------------------------------------------------

    Recapitulation:
    FIRST dynamic IP@ => 12.34.56.77
    NEW (static) IP@ => 12.34.56.78
    gateway IP@ => 1.2.3.4

    My questions are:
    1) need i to put 12.34.56.77 OR 12.34.56.78 as the Bcast for the second IP@ (static eth0:0) ?
    2) what is the value of "network" to put in "/etc/network/interfaces" ?

    Thanks a lot for your help !
     
  6. falko

    falko Super Moderator ISPConfig Developer

  7. falko

    falko Super Moderator ISPConfig Developer

    This web site should be able to help you: www.subnetmask.info :)
     
  8. stamy

    stamy New Member

    Thank's for your reply.

    I found the solution now:
    network 0.0.0.0
    netmask 255.255.255.255
    broadcast 12.34.56.78

    and it works fine (to be check really i need to wait until DNS records are uptodate), but sounds good now.

    Thanks.
     
  9. stamy

    stamy New Member

    No all is working but i have another problem with mutilple IP addresses.

    My problem is that i want the apache 1.3 server is listening on only one IP@ not on all IP addresses in httpd.conf.
    I add the "BindAddresse 12.34.56.78" in httpd.conf and restart ispconfig but it listen always on * instead of only one IP@, what is wrong here ?

    Thank's.
     
    Last edited: Aug 14, 2006
  10. falko

    falko Super Moderator ISPConfig Developer

    Try
    Code:
    Listen 12.34.56.78:80
    instead in httpd.conf.
     
  11. stamy

    stamy New Member

    Hello

    if i try "Listen 12.34.56.77:81" (i want that only this [email protected] listen on port 81, not the second) i have no more LISTEN at all with "netstat -tap"

    Before adding "Listen 12.34.56.77:81" netstat -tap gives *:81
    Now after adding this parameter i have nothing listen on port 81

    So for the moment i give up and configure the cisco firewall to block all incoming request except for port TCP/80 on this second IP@ ... (and maybe 443 later for https)

    The main problem is that when you have more then one IP@ some services are listening on this second IP@, for example web page for administration on port 81, named ...

    I have NOT checked the DNS and MX options for the second domain attached to the second IP@, so why named is listening on the second IP@ ?
    Anyway it is not so important because i have a firewall, but it may be interresting to be able to choose which services are listening on wich IP@ if we have more then one IP@ on a server ... (it is a dream ?)
     
  12. falko

    falko Super Moderator ISPConfig Developer

    But that's exactly what you asked for... :confused:

    Have a look here: http://www.howtoforge.com/forums/showthread.php?t=5966&highlight=listen-on
     
  13. stamy

    stamy New Member

    Sorry for the misunderstanding.

    I will try to be as clear as possible (my english is so bad).
    I have two IP@, but i want that the ispconfig server is only listening on port 81 on the first IP@ not on the second IP@.

    I have a PTR record for the second IP@ so if a web surfer try to connect to the second IP@ on port 81 nothing must be happend, but for now there is a page with a hint who asked the surfer to use https instead of http to access port 81 on this server ...

    Two IP@ but only one used by ispconfig, the other one must only be used by apache2 (not apache1.37 for ispconfig on port 81).

    So the ideal is:
    fisrt IP@ => ispconfig on port 81 (https with self signed certificat), normal apache2 on port 80
    second IP@ => apache2 on port 80, (no apache 1.3 available at any port what ever) + apache2 ssl on port 443 (with real CA certificat for commercial use...)

    what i have (netstat -tap) => *:81
    what i want (netstat -tap) => first IP@:81 (not * that means ALL interfaces)

    PS: For now i try to reinstall the complete system. The easy solution is to block port 81 on the second IP@ (easy with cisco firewall from my ISP webpage)

    Thank's.
     
  14. falko

    falko Super Moderator ISPConfig Developer

    But that's what I told you: use
    Code:
    Listen 1.2.3.4:81
    in /root/ispconfig/httpd/conf/httpd.conf and restart ISPConfig:
    Code:
    /etc/init.d/ispconfig_server restart
     

Share This Page