Multi-server | www-data missing for clients on master

Discussion in 'ISPConfig 3 Priority Support' started by SpeedyB, Jul 24, 2014.

  1. SpeedyB

    SpeedyB Member HowtoForge Supporter


    I have an issue with my multiserver setup.

    I don't know what happened but on the master server I am missing the www-data user in the client groups.
    On the slave servers the user is added to the client groups, but not on the master server.

    This is causing some issues for instance with the protected folder. It is giving the error:
    (13)Permission denied: /var/www/<domain>/web/<folder>/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

    After adding the user www-data to the group (and rebooting the server) it is working.

    Is this a bug or a setting which has changed (accidentally)?


  2. srijan

    srijan New Member HowtoForge Supporter

    I don't think it happens or any such bug. It could have changed accidentally.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess it must have been removed accidently. The ispconfig code does not make a difference if a server is master or slave when it adds a web, so the same code is axecuted on master and slaves and as it works on the slaves, it cant be a bug in the code.
  4. SpeedyB

    SpeedyB Member HowtoForge Supporter

    Is there a setting in the config which controls this? I know for sure that no-one has shell (root) access to modify the groups file...

    Might Debian have changed the apache user in between updates? that it is now www-data but was something else?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check if the correct apache user and group are set in ispconfig for the master server under System > Server config > web

    That is unlikely. I use debian as well and di not notice any changes.

Share This Page