Multi Server Setup

Discussion in 'Installation/Configuration' started by etts, Oct 30, 2019.

  1. etts

    etts New Member

    Greetings all
    Please could someone perhaps point out to me what I have missed. I am trying to get a simple multi server setup configured. I currently have 3 servers, they are all running on Debian 10.
    cp01 - I have all services installed on this machine
    ns01 - I have mysql webserver and dns installed on this machine
    ns02 - I have mysql webserver and dns installed on this machine

    Firstly I tried the lazy way and used the auto install script, Everything goes fine until the second server tries to connect to the master server, and I get a error "Unable to connect to mysql server Access denied for user 'root'@'ns01".
    Then I went through the tutorials and followed these two links

    So I gather there is a permission issue on the master sql server not having the correct permissions for my ns01 server. The strange thing is that if I go to phpmyadmin I can see that all relevant user accounts have all privileges on the ispconfig database. I have also added the relevant details needed in the hosts file to all servers


    What have I missed?

    Thanks in advance
  2. etts

    etts New Member

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Ensure that all servers are listed in the /etc/hosts files of all other servers.
    2) Check that mariadb on the master allows connections over the network.
    3) Test the connections from slave servers with the command:

    mysql -h -u root -p
  4. etts

    etts New Member

    Hi Till
    Ok, so ive really tried to do this without asking with no success.
    1) I have made sure that that all the entries are in the hosts file

    Code:       localhost        cp01        cp02       ns01       ns02
    ::1     localhost       ip6-localhost   ip6-loopback
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    #      vps260361       vps260361
    #    vps260361
    #    vps260361
    2) I have edited /etc/mysql/mariadb.conf.d/50-server.cnf file and commented out the bind address on cp01
    # this is only for the mysqld standalone daemon
    # * Basic Settings
    user                    = mysql
    pid-file                = /run/mysqld/
    socket                  = /run/mysqld/mysqld.sock
    #port                   = 3306
    basedir                 = /usr
    datadir                 = /var/lib/mysql
    tmpdir                  = /tmp
    lc-messages-dir         = /usr/share/mysql
    # Instead of skip-networking the default is now to listen only on
    # localhost which is more compatible and is not less secure.
    #bind-address            =
    3) When running the command mysql -h -u root -p
    I get authentication, But when I use the master sql root password, its not excepting it and I get the error
    ERROR 1045 (28000): Access denied for user 'root'@'' (using password: YES)
    I can however login with the above command if I use the slave mysql root password.

    What am I missing?
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    My guess is the database users for hosts are missing nor not set up adequately. Check again those tutorials or consult ISPConfig Manual.

Share This Page