multi server setup php

Discussion in 'Installation/Configuration' started by zineDzine, May 6, 2015.

  1. zineDzine

    zineDzine New Member

    i am installing the multiserver setup on debian 7.8 and i run into the issue of apache not serving php pages, it gives me a file instead.

    step >> 2 Installing The Web Server >> This server is the master server in our setup which runs the ISPConfig control panel interface.

    i looked up the apache config and that the mod php is enabled but it seems i missed something but can't quite see what ...

    Thanks in advance for the help.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    which php mode did you use in the website?
  3. zineDzine

    zineDzine New Member

    I haven't finnished installing ispconfig actually, so there is no websites yet ...
  4. zineDzine

    zineDzine New Member

    in the tutorial it states :

    Open the URL server_ip/phpmyadmin in a web browser, log in as MySQL root user and execute these MySQL queries:

    and i am not able to do it ...
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so you get the php code instead of the phpmyadmin interface? run:

    dpkg-reconfigure phpmyadmin

    and ensure that you select to configure phpmyadmin for apache (the option must be enambld in the list).
  6. zineDzine

    zineDzine New Member

    no, it is apache that makes me download a page instead showing it ...
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, thats why you should do the reconfigure. Please run the reconfigure as stated above and try again. If this wont help, the try:

    a2enmod php5
  8. zineDzine

    zineDzine New Member

    did the reconfigure and a2enmod php5 still not ... it is the case on all the servers ...

    same issue on all 5
  9. zineDzine

    zineDzine New Member

    Any thoughts anyone ?
  10. zineDzine

    zineDzine New Member


    apt-get --purge remove php5-common
    apt-get install php5 phpmyadmin

    now its ok ...

Share This Page