Multi-server Setup: package for mail,sql and web/ftp

Discussion in 'Installation/Configuration' started by itanium, Sep 5, 2009.

  1. skoena

    skoena Member

    Didn't find it first time when I tried to locate it, but I got it now.
     
    Last edited: May 7, 2010
  2. skoena

    skoena Member

    Ok thank you.
     
    Last edited: May 7, 2010
  3. skoena

    skoena Member

    Confused

    I have 2 servers.
    1 is in Datacenter and is Main server.


    This is slave server (setup in multiserver setup):
    This one is @home with me.

    Which passwords should be the same?
    Which user should connect from slave to master?

    Rudolf.
     
  4. skoena

    skoena Member

    Anybody that can help me?

    So what data should I enter on the main server and on the slave server?
     
  5. CSsab

    CSsab New Member

    Hi rudolfpietersma,

    I think from reading your posts that you have removed some required tables from your master server while you were uninstalling ISPConfig the first time and that this has led to your problems. You can access your phpmyadmin here:
    http://123.123.123.123/phpmyadmin (where 123.123.123.123 is your IP in /etc/network/interfaces)

    Here is a screenshot of phpmyadmin after a fresh install of mysql database on a Ubuntu system and also a new install of ispconfig.

    The easy way you can add or remove new users is by clicking on the privileges tab - tick the "add new user" box - hit enter. You can also remove users here and request that their database be dropped to keep your system clean.

    If you need to uninstall ISPConfig 3 for any reason the uninstall will remove entire dbispconfig, we need to remove only the user in mysql database which has been created on your mysql database by ISPConfig3 during the install. The reason for not removing the ISPConfig3 user is because you are uninstalling ISPConfig3 and therefore it no longer has access to your mysql database. This is why we get the "tables already exist" error.

    Hope this helps.
     

    Attached Files:

  6. skoena

    skoena Member

    Hi,
    Tnx for your message. But my last 2 messages are because of a new problem. The messaged before are already solved.

    My question is what settings should I use for the slave server that is at home with to connect and replicate with the master server that is in the datacenter.

    Rudolf.
     
  7. skoena

    skoena Member

    Till or anybody,
    Can you point me in the right direction?

    Rudolf.
     
  8. damir

    damir New Member

    You need to add user of slave server to your master server. That should contain both domain and ipadress of slave server. Don't forget to reload privileges on master server.

    Than if you can connect from slave to master using mysql -h command, than it's all setup correctly.
     
  9. skoena

    skoena Member

    Which user should I add to the master server, does it have a specific name?

    Rudolf.
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You have to add a root user. This root user has to be used only during install. The user that is used later by ispconfoig is created by the ispconfig installer. Please do not edit anything refßgarding this ispconfig user manually in the mysql settings. Only the root user has to be added before you install ispconfig.
     
  11. skoena

    skoena Member

    I can't get this to work.

    On my main server I added root user to connect from my slave ip in phpmyadmin:

    [​IMG]

    web01 is main server.
    backup is slave server.

    When I change things on main server via ispconfig it does not sync to the slave server.

    Jobqueue
    What to do next?
    Rudolf.
     
  12. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    1) stay the jobs for the slave in the jobqueue?
    2) Enable verbose logging for the slave in the server settings of the master server and check the ispconfig.og file on the slave.
     
  13. skoena

    skoena Member

    Hi Till,

    1) Yes they stay there.
    2) Sorry how to enable the logging?

    Rudolf.
     
  14. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

  15. skoena

    skoena Member

    I enabled the logging on the master but the /var/log/ispconfig/ispconfig.log on the slave stays empty?
     

Share This Page